Raised This Month: $99 Target: $400
 24% 

[L4D & L4D2] Hats (1.16) [02-Aug-2019]


Post New Thread Reply   
 
Thread Tools Display Modes
Silvers
AlliedModders Donor
Join Date: Aug 2010
Location: SpaceX
Old 04-02-2011 , 10:03   Re: [L4D & L4D2] Hats (v1.1.1 - 02-Apr-2011)
Reply With Quote #21

Quote:
Originally Posted by Leonardo View Post
No.
__________________
Silvers is offline
Optics233
Member
Join Date: Nov 2010
Old 04-02-2011 , 18:53   Re: [L4D & L4D2] Hats (v1.1.1 - 02-Apr-2011)
Reply With Quote #22

How does l4d_hats_menu work? I set it to "z" but pubs could still choose their own hats..

Also, there needs to be an admin command to turn off players hats. I can assign a hat to a player as an admin, but I can't reset them back to having no hat!

Otherwise , amazing plugin!
Optics233 is offline
Silvers
AlliedModders Donor
Join Date: Aug 2010
Location: SpaceX
Old 04-03-2011 , 11:34   Re: [L4D & L4D2] Hats (v1.2 - 03-Apr-2011)
Reply With Quote #23

@Optics233 make sure you deleted the previous l4d_hats.cfg and let the plugin make a new one, set the flag in there. It seems to work fine here so maybe try rebooting the server. Also added command to disable hats on players as you requested.

1.2
- Added sm_hatoffc for admins to disable hats on specific clients.
- Added cvar "l4d_hats_third" to control the previous update's addition.
__________________
Silvers is offline
Optics233
Member
Join Date: Nov 2010
Old 04-04-2011 , 21:38   Re: [L4D & L4D2] Hats (v1.2 - 03-Apr-2011)
Reply With Quote #24

Quote:
Originally Posted by Silvers View Post
@Optics233 make sure you deleted the previous l4d_hats.cfg and let the plugin make a new one, set the flag in there. It seems to work fine here so maybe try rebooting the server. Also added command to disable hats on players as you requested.

1.2
- Added sm_hatoffc for admins to disable hats on specific clients.
- Added cvar "l4d_hats_third" to control the previous update's addition.
I did all of those things. I have the flag set to "c." Took away my admin. Reset the server. Still let me use the !hat command even with no admin powers. Can you just make it so that it's toggleable? 0 anyone can use. 1 admins only.

Last edited by Optics233; 04-04-2011 at 21:42.
Optics233 is offline
Silvers
AlliedModders Donor
Join Date: Aug 2010
Location: SpaceX
Old 04-04-2011 , 21:47   Re: [L4D & L4D2] Hats (v1.2 - 03-Apr-2011)
Reply With Quote #25

Ahh I just found out whats wrong. It seems the config is not get read when the plugin starts with the server and creates the command. I would have to check the cvar within the command itself or wait till OnConfigsExecuted() I guess... For now I think you can make it read the flag by unloading and reloading the plugin (worked for me).
__________________
Silvers is offline
mentor
Member
Join Date: Apr 2011
Old 04-05-2011 , 02:28   Re: [L4D & L4D2] Hats (v1.3 - 05-Apr-2011)
Reply With Quote #26

my hat not show after choose hat.

when set l4d_hats_random "0"
mentor is offline
Optics233
Member
Join Date: Nov 2010
Old 04-05-2011 , 16:15   Re: [L4D & L4D2] Hats (v1.2 - 03-Apr-2011)
Reply With Quote #27

Quote:
Originally Posted by Silvers View Post
Ahh I just found out whats wrong. It seems the config is not get read when the plugin starts with the server and creates the command. I would have to check the cvar within the command itself or wait till OnConfigsExecuted() I guess... For now I think you can make it read the flag by unloading and reloading the plugin (worked for me).
Yup, whatever you did it fixed it. Plugin is working great now, I love it as a fun little add on for admins to play with. Excellent work!
Optics233 is offline
AtomicStryker
Veteran Member
Join Date: Apr 2009
Location: Teutonia!!
Old 04-05-2011 , 16:22   Re: [L4D & L4D2] Hats (v1.3 - 05-Apr-2011)
Reply With Quote #28

What the heck, when i first saw this thread i thought "obvious Aprils Fools"

Are you telling me this actually works
AtomicStryker is offline
Optics233
Member
Join Date: Nov 2010
Old 04-05-2011 , 16:27   Re: [L4D & L4D2] Hats (v1.3 - 05-Apr-2011)
Reply With Quote #29

Hmm.. now hatc isn't working. Keeps saying invalid player.
Optics233 is offline
Silvers
AlliedModders Donor
Join Date: Aug 2010
Location: SpaceX
Old 04-05-2011 , 16:33   Re: [L4D & L4D2] Hats (v1.3 - 05-Apr-2011)
Reply With Quote #30

Quote:
Originally Posted by mentor View Post
my hat not show after choose hat.

when set l4d_hats_random "0"
By default hats are invisible to yourself, you can change this with the cvar "l4d_hats_view" and by typing !hatview in chat. If theres another problem please let me know.


Quote:
Originally Posted by AtomicStryker View Post
What the heck, when i first saw this thread i thought "obvious Aprils Fools"

Are you telling me this actually works
LOL


Quote:
Originally Posted by Optics233 View Post
Hmm.. now hatc isn't working. Keeps saying invalid player.

Hmm that command requires the "z" flag, you could change the flag by using Command Access Overrides... I'll have a go later and fix if it's broken.
__________________
Silvers is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 22:43.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode