Raised This Month: $248 Target: $400
 62% 

[DoD:S] Joinserver sounds


Post New Thread Reply   
 
Thread Tools Display Modes
Author
Misery59
Junior Member
Join Date: Jul 2008
Plugin ID:
883
Plugin Version:
1.1
Plugin Category:
Fun Stuff
Plugin Game:
Day of Defeat: Source
Plugin Dependencies:
    Servers with this Plugin:
    13 
    Plugin Description:
    A sound to each map in introduction
    Old 05-19-2009 , 08:06   [DoD:S] Joinserver sounds
    Reply With Quote #1

    Hello all,

    A sound of welcome (music) is emitted when the player arrives on the server !

    You have the choice between the plugin with a single sound and the plugin with several sounds in the compressed file.

    In each changemap, you have an (unpredictable) various sound from a list of sounds randomly.

    The plugin with several sound have for the moment 10 sounds.


    For add/Delete sounds in list of sounds:
    you must compile it yourself. there are some settings you have to made if you change sounds.

    1: Define how many sounds you have in the SP file.
    Code:
    Code:
    #define MAXSOUNDS 4
    2: And then insert the sounds you need in the SP file.
    look at the directorys.
    Code:
    Code:
    new String:js_add_sounds_name[][] = {
            "sound/joinserver/welcome.mp3",
            "sound/joinserver/join_db_od.mp3",
            "sound/joinserver/join_flight.mp3",
            "sound/joinserver/join_td_rockhouse.mp3"
            }
     
    new String:js_pre_sounds_name[][] = {
            "joinserver/welcome.mp3",
            "joinserver/join_db_od.mp3",
            "joinserver/join_flight.mp3",
            "joinserver/join_td_rockhouse.mp3"
            }
    3: Compile the plugin.
    Dont forget to copy the sounds in the right directory on your gameserver. and on your FAST_FTP if you have one..


    Command:
    - No command

    Installation:
    - Put sm_dod_joinserver.smx in " dod / addons / sourcemod / plugins "
    - Put the sound of welcome in the file " dod / sound / joinserver "
    - Relaunch the server

    CHANGELOG:
    Version 1.1 (NEW)
    - Several sounds (This version have new small sounds)

    REPORTED BUGS:
    - No bug for a long time

    WARNING:
    this plugin was creates for a long time, it has no known bug and already works on numerous servers. Her author wishes to make it share to the community, but will make modifications above only if need be.

    SERVERS RUNNING THIS PLUGIN:
    http://www.game-monitor.com/search.p...&type=variable


    Attached Files
    File Type: zip joinserver.zip (3.52 MB, 5179 views)

    Last edited by Misery59; 11-12-2009 at 07:42.
    Misery59 is offline
    valentin1000
    Junior Member
    Join Date: May 2006
    Old 09-14-2009 , 12:42   Re: [DoD:S] Joinserver sounds
    Reply With Quote #2

    Hi, in my windows server not work.

    Any special configuration?

    Thanks
    valentin1000 is offline
    Kezman
    New Member
    Join Date: Sep 2009
    Old 09-14-2009 , 12:45   Re: [DoD:S] Joinserver sounds
    Reply With Quote #3

    Hello all,

    First of all, I would like to thanks for this plugin. I am writing this post because in my server it does not work. I will explain:

    Nowadays I have the plugin installed in my server. The server works in Windows. I have installed this plugin, because I want to use the part of the plugin that, in each changemap, during the load, make a different sound, or music sounds.

    I have put in my server the plugin default and correctly. When I or another member connect to my server, the sound files download from the server. However when there is a changemap and it is loading, you can't listen anything.

    Could someone help me??

    Thank you in advance

    Kezman


    PD: Sorry for my bad english. I am spanish an my english is not very good.
    Kezman is offline
    valentin1000
    Junior Member
    Join Date: May 2006
    Old 09-15-2009 , 14:39   Re: [DoD:S] Joinserver sounds
    Reply With Quote #4

    Juerrr... que bien te explicas Kezman... leņe...
    valentin1000 is offline
    JawsDK
    Junior Member
    Join Date: Oct 2009
    Old 10-28-2009 , 10:15   Re: [DoD:S] Joinserver sounds
    Reply With Quote #5

    Hmmm...

    Failed to load sound "joinserver\intro6.mp3", file probably missing from disk/repository

    Wuts wrong? Its downloading it allright, but the error comes in the clients console.
    JawsDK is offline
    JawsDK
    Junior Member
    Join Date: Oct 2009
    Old 10-28-2009 , 10:28   Re: [DoD:S] Joinserver sounds
    Reply With Quote #6

    Ohh yeah my code string is:

    };

    new String:js_add_sounds_name[][] = {
    "dod/sound/joinserver/intro1.mp3",
    "dod/sound/joinserver/intro2.mp3",
    "dod/sound/joinserver/intro3.mp3",
    "dod/sound/joinserver/intro4.mp3",
    "dod/sound/joinserver/intro5.mp3",
    "dod/sound/joinserver/intro6.mp3",
    "dod/sound/joinserver/intro7.mp3",
    "dod/sound/joinserver/intro8.mp3",
    "dod/sound/joinserver/intro9.mp3",
    "dod/sound/joinserver/intro10.mp3"
    }

    new String:js_pre_sounds_name[][] = {
    "joinserver/intro1.mp3",
    "joinserver/intro2.mp3",
    "joinserver/intro3.mp3",
    "joinserver/intro4.mp3",
    "joinserver/intro5.mp3",
    "joinserver/intro6.mp3",
    "joinserver/intro7.mp3",
    "joinserver/intro8.mp3",
    "joinserver/intro9.mp3",
    "joinserver/intro10.mp3"
    }
    JawsDK is offline
    retsam
    Veteran Member
    Join Date: Aug 2008
    Location: so-cal
    Old 10-28-2009 , 13:56   Re: [DoD:S] Joinserver sounds
    Reply With Quote #7

    Its either not on the server or not precached.
    retsam is offline
    JawsDK
    Junior Member
    Join Date: Oct 2009
    Old 10-28-2009 , 15:57   Re: [DoD:S] Joinserver sounds
    Reply With Quote #8

    Precached?
    JawsDK is offline
    JawsDK
    Junior Member
    Join Date: Oct 2009
    Old 10-28-2009 , 18:57   Re: [DoD:S] Joinserver sounds
    Reply With Quote #9

    Ok, heres the main problem.

    Im running a DoD:s server on a:

    Intel Atom 1.6 GHz
    4 GB DDR2 800 MHz
    Bandwidth 30/30 Mbit
    OS: MS Server 2008 32-bit
    (the server is on my local network)

    Its been two days since the server came up and its running without any major flaws. Until i startet installing plugins. Im having major issues with the plugin : sm_dod_joinserver.smx sourcemode.

    The plugin is loaded, testet it with the "sm plugins load sm_dod_joinserver" command, reply: already loaded.
    The main problem is im getting a error from the client console that says:

    Failed to load sound "joinserver\intro4.mp3", file probably missing from disk/repository"

    The original .sp file looks like this (the whole file can be found at the link above)

    new String:js_add_sounds_name[][] = {
    "sound/joinserver/intro1.mp3",
    "sound/joinserver/intro2.mp3",
    "sound/joinserver/intro3.mp3",
    "sound/joinserver/intro4.mp3",
    "sound/joinserver/intro5.mp3",
    "sound/joinserver/intro6.mp3",
    "sound/joinserver/intro7.mp3",
    "sound/joinserver/intro8.mp3",
    "sound/joinserver/intro9.mp3",
    "sound/joinserver/intro10.mp3"
    }

    new String:js_pre_sounds_name[][] = {
    "joinserver/intro1.mp3",
    "joinserver/intro2.mp3",
    "joinserver/intro3.mp3",
    "joinserver/intro4.mp3",
    "joinserver/intro5.mp3",
    "joinserver/intro6.mp3",
    "joinserver/intro7.mp3",
    "joinserver/intro8.mp3",
    "joinserver/intro9.mp3",
    "joinserver/intro10.mp3"
    }

    This is the one im using now, i have edited to match my own music:

    };

    new String:js_add_sounds_name[][] = {
    "sound/joinserver/pulpfiction.mp3",
    "sound/joinserver/wipeout.mp3",
    "sound/joinserver/watchtower.mp3",
    "sound/joinserver/surfinbird.mp3",
    "sound/joinserver/letsgetready.mp3",
    "sound/joinserver/mozart.mp3",
    "sound/joinserver/nationarmy.mp3",
    "sound/joinserver/mysharona.mp3",
    "sound/joinserver/highwaytohell.mp3",
    "sound/joinserver/eyeoftiger.mp3"
    }

    new String:js_pre_sounds_name[][] = {
    "joinserver/pulpfiction.mp3",
    "joinserver/wipeout.mp3",
    "joinserver/watchtower.mp3",
    "joinserver/surfinbird.mp3",
    "joinserver/letsgetready.mp3",
    "joinserver/mozart.mp3",
    "joinserver/nationarmy.mp3",
    "joinserver/mysharona.mp3",
    "joinserver/highwaytohell.mp3",
    "joinserver/eyeoftiger.mp3"

    (the sound files is located in : C:\srcds\orangebox\dod\sound\joinserver)

    I dont think its the plugin thats cocking it all up. The funny thing is, even after i have made the changes and configued the .sp file and restarted the server, when the client connects it still shows that it is trying to download the : "sound/joinserver/intro(?).mp3" even tho the changes have been made in the .sp file. But nevertheless, its not working, the client is not reciveing the files from the server even tho its showing the download process. And its not only the joinserver plugin that im haveing problems with. I have a callmedic.smx which runs on the server, the commands itself ingame works, but people can't get the bandage.mp3 so theres no sound when they bandage. So all in all no one can download anything from my server.

    Just to be sure that its not another plugin that is causing the problem i took the liberty to post a picture of the loaded plugins:

    [IMG]http://img62.**************/img62/4815/capturelq.png[/IMG]

    and the server.cfg:

    sv_pure 0
    sv_allowdownload 0
    mp_allowspectators 1
    mp_chattime 0
    sv_voiceenable 1
    sv_rcon_minfailuretime 1
    sv_maxrate 25000
    decalfrequency 60
    sv_logbans 0
    sv_logecho 0
    sv_logsdir /srcds/orangebox/Server logs
    mp_flashlight 0
    sv_turbophysics 1
    sv_stopspeed 50
    sv_friction 8
    sv_password "test"
    sv_cheats 1
    sv_lan 0
    sv_region 3
    log "on"
    sv_logfile 1
    sv_autobalance 0
    sv_log_onefile 1
    mp_allowrandomclass 1
    mp_allowspectators 0
    mp_autocrosshair 1
    mp_autokick 0
    mp_cancelwarmup 1
    mp_decals 200
    mp_defaultteam 0
    mp_falldamage 20
    mp_flashlight 1
    mp_footsteps 1
    mp_forcecamera 1
    mp_forcerespawn 1
    mp_fraglimit 0
    mp_friendlyfire 1
    mp_limit_allies_assault 2
    mp_limit_allies_mg 1
    mp_limit_allies_rifleman -1
    mp_limit_allies_rocket 2
    mp_limit_allies_sniper 1
    mp_limit_allies_support -1
    mp_limit_axis_assault 2
    mp_limit_axis_mg 1
    mp_limit_axis_rifleman -1
    mp_limit_axis_rocket 2
    mp_limit_axis_sniper 1
    mp_limit_axis_support -1
    mp_limitteams 3
    mp_restartwarmup 1
    mp_timelimit 15
    mp_warmup_time 0
    mp_weaponstay 0
    dod_freezecam 1 (disables "killcam")

    //medic Plugin
    sm_medic_delay 0
    sm_medic_enabled 1
    sm_medic_freeze_time 0
    sm_medic_health 25
    sm_medic_yell 5.0
    sm_medic_maxhealth 50
    sm_medic_kits 3
    sm_medic_alpha 50

    mapcyclefile "mapcycle.txt"

    Im all outta ideas and options, hope theres a "big brain on bratt" around here.

    Thank you for your time!

    EDIT!: The .sp file was not compiled! Have done that now and it's still the same

    Last edited by JawsDK; 10-28-2009 at 19:35.
    JawsDK is offline
    JawsDK
    Junior Member
    Join Date: Oct 2009
    Old 10-28-2009 , 20:10   Re: [DoD:S] Joinserver sounds
    Reply With Quote #10

    Ok bear with me, this might get abit confusing.

    Me and Xp3r7 had a look at the problem (well he had a look) and we found out the .sp wasnt compiled. So i did that for startes, but no luck :/ Then we changes the #define MAXSOUNDS from 10 to 9 in case the script/plugin coulden't handel 2 digits. Then all of a sudden a new error popped up:

    [IMG]http://img246.**************/img246/9486/capturenc.png[/IMG]

    The problem was i forgot to change the #define MAXSOUNDS 10 to
    #define MAXSOUNDS 9 which caused the "Array" error. I corrected it and its still the same. :/
    Now im not even getting the SV_startSound command again.
    JawsDK is offline
    Reply


    Thread Tools
    Display Modes

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off

    Forum Jump


    All times are GMT -4. The time now is 03:59.


    Powered by vBulletin®
    Copyright ©2000 - 2020, vBulletin Solutions, Inc.
    Theme made by Freecode