Raised This Month: $66 Target: $400
 16% 

Join / Leave Sounds and Sayings for Admins / Players


Post New Thread Reply   
 
Thread Tools Display Modes
Plugin Info:     Modification:   ALL        Category:   Fun Stuff        Approver:   devicenull (200)
Zor
Veteran Member
Join Date: Mar 2004
Location: Toronto, ON
Old 08-19-2004 , 11:39   Join / Leave Sounds and Sayings for Admins / Players
Reply With Quote #1

Hello all. This plugin was requested in the following:

http://forums.alliedmods.net/showthread.php?t=4947

I looked at the bugblatter one for adminmod and was HUGE! So I made a smaller version. Its pretty basic, you edit the joinleave.txt and add your steam ids then the saying you want when you join the server, and the sound to play. Then add the saying that you want when you leave and the sound to play:

Code:
"Steamid" "sayingjoin" "joinsound" "sayingleave" "leavesound"
"STEAM_0:0:000000 or IP" "Player has joined! Beware!" "joinleavesounds/imhere.wav" "Player has left the building" "joinleavesounds/adios.wav"
Now, beware the more players you add, you can only add 64 this can be changed if your crazy enough to do so! The more sound files a person joining your server will have to download. Ok that warning outa the way.

Version Control:
Code:
v0.1
  -Be!
  -Created the lists and loads them.  When player gets into server it plays sound and shows saying.
  -When leaving server it shows saying and plays sound.
v0.2
- Corrected the sounds/ adding to the front of the file name.  This may or may not have affected the working of the program but better off not sorry!
v0.2b
- Repaired for amxx v0.20
- Changed to config dir instead of custom dir
v0.2c
- Moved the plugin_cfg into plugin_init so that the files are loaded first
v0.2d
- Moved the loading of the joinleave.txt into plugin_precache so that the files are loaded first
v0.2e
- Converted the file reading loop to increment pos at the end of the loop instead of using the return to increment it.  This is to fix the read errors that I have been recieving reports about
- Added code that will determine where the joinleave.txt will be.
v0.2f 
- Changed code to look at authid or ip, thanks to hasta 
v0.2g
- Added error checking in the precache to fix an error that could occure when no file loaded
- Added error checking in the join and leave area
v0.3
- Made it compatible with Amxmodx 1.0
v0.3a
- Changed the length of the arrays to make sure that exotic names are not truncated
v0.3b
- Fixed the no spaces rules in the joinleave.txt
v0.4
- Fixed a problem with leave sounds
v0.5
- Added a timer for the says
Quote:
***IMPORTANT***
<mod dir>/addons/amxmodx/config/joinleave.txt
To Do:
Code:
v1.0
-Make it so that a default saying and wav are played for normal players
-Make it so that a default saying and wav are played for any admin not setup admins
Ok I hope this helps out for anyone.

Cheers!
Attached Files
File Type: txt joinleave.txt (220 Bytes, 8741 views)
File Type: sma Get Plugin or Get Source (amxx_playersounds.sma - 8351 views - 6.4 KB)
__________________
Zor is offline
Send a message via AIM to Zor Send a message via MSN to Zor Send a message via Yahoo to Zor
kryptonyte
Senior Member
Join Date: Aug 2004
Location: South Carrolinaa
Old 08-19-2004 , 14:21  
Reply With Quote #2

looks great but one question. when you add the sounds in the joinleave.txt are the directories based on the mod's dir or amxx dir?
kryptonyte is offline
Send a message via ICQ to kryptonyte Send a message via AIM to kryptonyte Send a message via MSN to kryptonyte Send a message via Yahoo to kryptonyte
Zor
Veteran Member
Join Date: Mar 2004
Location: Toronto, ON
Old 08-19-2004 , 18:30  
Reply With Quote #3

well Im not to sure how it works...now Im adding the sounds/ to the front of the file name in the text. It may not need it as I have seen other plugins that use the misc folder in the sounds directory and it looks like this

Code:
misc/soundname
And thats what they use...will look at another plugin I have that uses sounds...

Ok it seems that I have it wrong...you dont need to add the sounds directory...will fix this up and repost it. As well as you need to add the .wav to the end. So it should look like this:

Code:
misc/soundname.wav
Now you can put it wherever you want but it has to be under the sounds/ directory. So if you want it in timbuck3 the heiarchy will look like this:

Quote:
<mod directory>/sounds/timbuck3/soundname.wav
Sooo, if you place the file in above location and put into the joinleave.txt for a player the following:

Code:
timbuck3/soundname.wav
Cheers!
__________________
Zor is offline
Send a message via AIM to Zor Send a message via MSN to Zor Send a message via Yahoo to Zor
kryptonyte
Senior Member
Join Date: Aug 2004
Location: South Carrolinaa
Old 08-19-2004 , 19:54  
Reply With Quote #4

ok thanks now i can start configuring it
kryptonyte is offline
Send a message via ICQ to kryptonyte Send a message via AIM to kryptonyte Send a message via MSN to kryptonyte Send a message via Yahoo to kryptonyte
Zor
Veteran Member
Join Date: Mar 2004
Location: Toronto, ON
Old 08-28-2004 , 22:42  
Reply With Quote #5

*bump* Any further info on testing? Does it work well? Haven't tried it yet as I have been away.

Cheers!
__________________
Zor is offline
Send a message via AIM to Zor Send a message via MSN to Zor Send a message via Yahoo to Zor
kryptonyte
Senior Member
Join Date: Aug 2004
Location: South Carrolinaa
Old 08-28-2004 , 23:13  
Reply With Quote #6

i havent been able to test it yet really since it wont compile right in amxx .20. i cant remember why just some error with it. i will try again as soon as i can fix all the other problems im having with amxx .2. mainly mysql problems.
kryptonyte is offline
Send a message via ICQ to kryptonyte Send a message via AIM to kryptonyte Send a message via MSN to kryptonyte Send a message via Yahoo to kryptonyte
Zor
Veteran Member
Join Date: Mar 2004
Location: Toronto, ON
Old 08-29-2004 , 00:23  
Reply With Quote #7

Well by the look of it the online compiler isnt working and this could be the problem. Get a copy of the sma and then compile it with the new stuff.

Cheers!
__________________
Zor is offline
Send a message via AIM to Zor Send a message via MSN to Zor Send a message via Yahoo to Zor
kryptonyte
Senior Member
Join Date: Aug 2004
Location: South Carrolinaa
Old 08-29-2004 , 10:08  
Reply With Quote #8

ive just been lazy lately. i just got my server to restart automatically and im fixin all those bugs, now im focusing on getting the mysql to work but no one will tell me how to fix the problems. something about changing mysql ?????. that plus having a hurricane outside ur window all kinda changes everything.
kryptonyte is offline
Send a message via ICQ to kryptonyte Send a message via AIM to kryptonyte Send a message via MSN to kryptonyte Send a message via Yahoo to kryptonyte
Zor
Veteran Member
Join Date: Mar 2004
Location: Toronto, ON
Old 08-29-2004 , 11:50  
Reply With Quote #9

More specifics on the sql? I may be able to help but not without lots of information.

Cheers!
__________________
Zor is offline
Send a message via AIM to Zor Send a message via MSN to Zor Send a message via Yahoo to Zor
kryptonyte
Senior Member
Join Date: Aug 2004
Location: South Carrolinaa
Old 08-29-2004 , 14:50  
Reply With Quote #10

yeah well i have about as much information as you do. NONE. here is where i posted asking for help
http://forums.alliedmods.net/showthr...?p=51675#54453
__________________

Kaboom Clan Site
Visit Kaboom Counter-Strike 1.6 Server: 24.88.56.188:27015
Visit Kaboom DOD Server: 24.88.56.188:2030
kryptonyte is offline
Send a message via ICQ to kryptonyte Send a message via AIM to kryptonyte Send a message via MSN to kryptonyte Send a message via Yahoo to kryptonyte
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:40.


Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Theme made by Freecode