Raised This Month: $68 Target: $400
 17% 

CSO Costumes v3.0


Post New Thread Reply   
 
Thread Tools Display Modes
Smilex_Gamer
Member
Join Date: Apr 2017
Location: Portugal
Old 08-31-2019 , 21:08   Re: CSO Costumes
Reply With Quote #31

Update 2.0 (01/09/2019):

Removed all hardcoded costumes. Added a new way to add costumes (using an INI file).
Smilex_Gamer is offline
Smilex_Gamer
Member
Join Date: Apr 2017
Location: Portugal
Old 09-01-2019 , 11:59   Re: CSO Costumes
Reply With Quote #32

Update 2.1 (01/09/2019):

Small bug fix regarding model change in Player Spawn.
Smilex_Gamer is offline
Smilex_Gamer
Member
Join Date: Apr 2017
Location: Portugal
Old 09-03-2019 , 13:02   Re: CSO Costumes
Reply With Quote #33

Update 2.2 (03/09/2019):

Added a new console command to give Cash (only users with flag ADMIN_RCON can use it).
Smilex_Gamer is offline
Smilex_Gamer
Member
Join Date: Apr 2017
Location: Portugal
Old 09-05-2019 , 18:50   Re: CSO Costumes
Reply With Quote #34

Update 2.3 (05/09/2019):

Added new Costumes from CSO (when it gets released in CSN:Z, I will verify the translations).
Smilex_Gamer is offline
Smilex_Gamer
Member
Join Date: Apr 2017
Location: Portugal
Old 09-06-2019 , 20:44   Re: CSO Costumes
Reply With Quote #35

Update 2.4 (07/09/2019):

From now on, if any type of costume has no costumes in costumes.ini, it will show a message in the chat saying that there are no costumes of that type of costume available in the moment (whenever you try to open your inventory or the shop of that type of costume, it will show that message).
Smilex_Gamer is offline
Old 09-12-2019, 11:15
Dexon
This message has been deleted by Dexon. Reason: Fixed.
Dexon
Member
Join Date: Aug 2019
Old 09-12-2019 , 12:04   Re: CSO Costumes v2.4
Reply With Quote #36

Dear @Smilex_Gamer.
Your awesome plugin not working for me. If the ZP Support undefined it works, but if I define the ZP Support it doesn't react to commands, etc... Using zp 4.3. Any fix?
Dexon is offline
Smilex_Gamer
Member
Join Date: Apr 2017
Location: Portugal
Old 09-12-2019 , 17:11   Re: CSO Costumes v2.4
Reply With Quote #37

Quote:
Originally Posted by Dexon View Post
Dear @Smilex_Gamer.
Your awesome plugin not working for me. If the ZP Support undefined it works, but if I define the ZP Support it doesn't react to commands, etc... Using zp 4.3. Any fix?
Hmm that's odd. I'm going to test it right now and then I tell you if I got the same results.

P.S: I'm going to use AmxModX 1.8.2 and Zombie Plague 4.3 Fix 5a
Smilex_Gamer is offline
Smilex_Gamer
Member
Join Date: Apr 2017
Location: Portugal
Old 09-12-2019 , 22:04   Re: CSO Costumes v2.4
Reply With Quote #38

Quote:
Originally Posted by Dexon View Post
Dear @Smilex_Gamer.
Your awesome plugin not working for me. If the ZP Support undefined it works, but if I define the ZP Support it doesn't react to commands, etc... Using zp 4.3. Any fix?
Well, after some hours (yes, hours because I wasn't understanding the problem) I got the problem and fixed it. Firstly you'll need to have "cs_player_models_api" (include and plugin) in your server to work.
The reason why you don't have it originally with your Zombie Plague 4.3 is because only since Zombie Plague 5.0 until earlier versions (including the last version: Zombie Plague 5.0.8a) it didn't use that include and plugin, but now it uses. And one important thing that I didn't mention before: When I made the Zombie Plague Support (in version 1.5), I made it based on Zombie Plague 5.0.8a and I didn't test it in other versions like Zombie Plague 4.3 (my fault, sorry).
So, long story short, I added a new define called "ZP43_SUPPORT" in the line 13 to support Zombie Plague versions from ZP 4.3 to the very first version (at least I think it does, but now nobody uses versions before ZP 4.3 though). If your server uses those versions before 5.0, then uncomment it. If your ZP version is 5.0 or newer, then leave as it is and it will work fine.
Also, I'm going to leave here a link to "cs_player_models_api" include and plugin: https://forums.alliedmods.net/showthread.php?t=161255

P.S: I hope now everything is fine

Last edited by Smilex_Gamer; 09-12-2019 at 22:08.
Smilex_Gamer is offline
Smilex_Gamer
Member
Join Date: Apr 2017
Location: Portugal
Old 09-12-2019 , 22:31   Re: CSO Costumes v2.5
Reply With Quote #39

Update 2.5 (13/09/2019):

Added a new define called "ZP43_SUPPORT" in the line 13 to support Zombie Plague versions since ZP 4.3 until the very first version (at least I think it does, but I didn't even test it and now nobody uses versions before ZP 4.3 though).
If your ZP version is 4.3 or older, then uncomment it and download (and install) cs_player_models_api here (you will need the include to compile my plugin and its plugin "cs_player_models_api.amxx" installed in your server).
If your ZP version is 5.0 or newer, then leave as it is and it will work fine (you still need to have "#define "ZP_SUPPORT" uncommented to support any Zombie Plague Mod version).
Smilex_Gamer is offline
Dexon
Member
Join Date: Aug 2019
Old 09-13-2019 , 09:31   Re: CSO Costumes v2.5
Reply With Quote #40

Thank you so much. It works! Btw, I'm using ZP 4.3 only because there are so many great old plugins for 4.3 version, and 5.0 doesn't compatible with them, even with the compatible plugin.
But there is a big problem, for me. If I active a model, the server starts to create big lags. I don't even know why.

Malformed packet size (2782, 1230) => Console msg.

Last edited by Dexon; 09-13-2019 at 11:26.
Dexon is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 20:08.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode