Monthly Target: $400 Donations: $340
 85% 

Translations encoding


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
Jje
Junior Member
Join Date: Oct 2011
Old 03-30-2012 , 05:38   Translations encoding
Reply With Quote #1

Hi guys! I have a problem with encoding. I tried to save plugin with cyrillic encoding in UTF8, cp1251(cyrillic), but compiler returns errors or if plugin has successfully compiled cyrillic sybmbols don't appear, instead them there are spaces. Which encoding plug-ins need to save?
P.S Sry for my bad English
Jje is offline
Send a message via ICQ to Jje Send a message via Skype™ to Jje
Arkshine
AMX Mod X Plugin Approver
Join Date: Oct 2005
Old 03-30-2012 , 05:57   Re: Translations encoding
Reply With Quote #2

UTF-8 without BOM and don't use AMXX Studio to compile. Drag and drop directly the .sma on compile.exe.
__________________
Working on : CS Weapon Mod (72%) , MonsterAI (PAUSED),

Arkshine is online now
Jje
Junior Member
Join Date: Oct 2011
Old 03-30-2012 , 06:51   Re: Translations encoding
Reply With Quote #3

I saved plugins in Utf-8 without BOM and compile it with compile.exe ! Maybe I'm doing something wrong:
i edit the source in Notepad++, select all the code and lick convert to utf-8 (without BOM). then compile it with compile.exe. When I put in on server, cyrillic symbols don't appear! When i use online compiler, everything appears normal. Maybe I should use another text editor? What you can advise?

Last edited by Jje; 03-30-2012 at 06:53.
Jje is offline
Send a message via ICQ to Jje Send a message via Skype™ to Jje
.Dare Devil.
Veteran Member
Join Date: Sep 2010
Location: Where am i ?
Old 03-30-2012 , 12:46   Re: Translations encoding
Reply With Quote #4

Quote:
Originally Posted by Jje View Post
I saved plugins in Utf-8 without BOM and compile it with compile.exe ! Maybe I'm doing something wrong:
i edit the source in Notepad++, select all the code and lick convert to utf-8 (without BOM). then compile it with compile.exe. When I put in on server, cyrillic symbols don't appear! When i use online compiler, everything appears normal. Maybe I should use another text editor? What you can advise?
Some unicodes can not be show in Hl engine.
There are so small font.
.Dare Devil. is offline
fysiks
Veteran Member
Join Date: Sep 2007
Location: Flatland, USA
Old 03-30-2012 , 20:00   Re: Translations encoding
Reply With Quote #5

Notepad++ is not at fault here.
__________________
fysiks is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:25.


Powered by vBulletin®
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Theme made by Freecode