Monthly Target: $400 Donations: $140
 35% 

Notices

[L4D/L4D2] VS Bug Fix


Post New Thread Reply   
 
Thread Tools Display Modes
Author
Pescoxa
Member
Join Date: Dec 2009
Plugin ID:
1668
Plugin Version:
2.9.3
Plugin Category:
Server Management
Plugin Game:
Left 4 Dead
Plugin Dependencies:
    Servers with this Plugin:
    11 
    Plugin Description:
    Fix for Versus Server shutting down and Bots starting without players
    Old 05-15-2010 , 13:05   [L4D/L4D2] VS Bug Fix
    Reply With Quote #1

    This plugin handles the game in some game modes to change some cvars.

    Sometimes the game starts and the bots start the game before the players get in! This plugin freezes the bots (survivor and infected) until a human player get in and left the safe area. When this occours, the bots start moving.

    It allows you play versus mode without survivor players and does not close the game (sb_all_bot_team [L4D] and sb_all_bot_game [L4D2]).

    Hooks: mp_gamemode, sb_stop, sb_all_bot_team or sb_all_bot_game, director_ready_duration (how it works?), nb_stop and director_no_mobs.

    Command: sm_unfreezebots (force to restore AI)

    When the round starts, all AI is disabled and it starts working again when a human player left the safe area. While the survivors are in the safe (without get out sometime) the will have the God Mode enabled.

    I've been testing this plugin since version 0.1. I changed it a lot and now, in the current version, I think it's OK!

    Let me know if it actually works!

    * I changed some events that skrewed up the plugin, but I found the solution in another plugin, then I'll replicate it to this plugin. - FIXED *

    * NEW VERSION IS OUT!!! 2.9.3 *

    Changelog:

    * 2.9.3
    - sb_all_bot_team to L4D and to sb_all_bot_game to L4D2;
    - Russian language added;

    * 2.9.2
    - sb_all_bot_team to sb_all_bot_game;

    * 2.9.1
    - All modes are handled;

    * 2.9
    - Translation: pt-br and us-en;
    - Some Bug fixes about god mode;
    - Code Review;

    * 2.8
    - Initial public release.

    TODO:

    - Nothing
    Attached Files
    File Type: sp Get Plugin or Get Source (l4d_sm_vsbugfix.sp - 3619 views - 9.6 KB)
    File Type: txt l4d_sm_vsbugfix.phrases.txt (563 Bytes, 2154 views)

    Last edited by Pescoxa; 02-03-2011 at 15:50. Reason: New Version
    Pescoxa is offline
    le0n_
    Junior Member
    Join Date: Mar 2010
    Old 11-14-2010 , 16:52   Re: [L4D/L4D2] VS Bug Fix
    Reply With Quote #2

    sry but my english is not very good , i am not shure how to make this to work.
    Because i again see server shut down , if i w8 try to play only with bots or w8 2 min and server shut down
    le0n_ is offline
    Galaxy9000
    Senior Member
    Join Date: Dec 2009
    Location: Munich
    Old 11-21-2010 , 08:00   Re: [L4D/L4D2] VS Bug Fix
    Reply With Quote #3

    Quote:
    Originally Posted by le0n_ View Post
    sry but my english is not very good , i am not shure how to make this to work.
    Because i again see server shut down , if i w8 try to play only with bots or w8 2 min and server shut down
    Check your server.cfg also for the cvar "sb_all_bot_team", does it have 1?!
    __________________
    L4D2: 32 Player Versus (Stable) w/ Inf. Bots, L4Toolz, SuperVersus, MultiTanks, HP Reg, SpitterSupergirl, ZombieSelectMenu, Teampanel.

    CSS: 64 Player w/ Bots, ES XA, many Plugins (Splahdmg, ExplosiveDeath etc.), Spawnpointgen.

    http://www.gametracker.com/server_info/ NO PUB SERVERS ATM
    Galaxy9000 is offline
    Junior Member
    Join Date: Dec 2010
    Location: Kiev, Ukraine
    Old 01-03-2011 , 16:32   Re: [L4D/L4D2] VS Bug Fix
    Reply With Quote #4

    Have error (((
    Code:
    L 01/03/2011 - 22:30:54: [SM] Native "SetConVarInt" reported: Invalid convar handle 0 (error 4)
    L 01/03/2011 - 22:30:54: [SM] Displaying call stack trace for plugin "l4d_sm_vsbugfix.smx":
    L 01/03/2011 - 22:30:54: [SM]   [0]  Line 73, l4d_sm_vsbugfix.sp::Init()
    L 01/03/2011 - 22:30:54: [SM]   [1]  Line 296, l4d_sm_vsbugfix.sp::Event_Round_Start()
    I've translated l4d_sm_vsbugfix.phrases.txt to Russian. Here it is:

    Code:
    "Phrases"
    {
    	//""Normal \x01 
    	//""Verde \x03 
    	//""Amarelo \x04 
    	//""Verde \x05
    	
    	"BOTsAreUnfrozen"
    	{
    		"en"		"BOTs are unfrozen."
    		"pt"		"BOTs estão descongelados."
    		"ru"		"БОТы разморожены."
    	}
    	
    	"GodOn"
    	{
    		"en"		"You had God Mode turned on."
    		"pt"		"Você teve o modo Deus ativado."
    		"ru"		"Вы включили режим Бога."
    	}
    	
    	"GodOff"
    	{
    		"en"		"You had God Mode turned off."
    		"pt"		"Você teve o modo Deus desativado."
    		"ru"		"Вы отключили режим Бога."
    	}
    	
    }
    __________________

    Last edited by [email protected] Rasta; 01-03-2011 at 16:45.
    MON@H Rasta is offline
    Send a message via ICQ to MON@H Rasta Send a message via Skype™ to MON@H Rasta
    le0n_
    Junior Member
    Join Date: Mar 2010
    Old 01-24-2011 , 17:33   Re: [L4D/L4D2] VS Bug Fix
    Reply With Quote #5

    this not work on me
    pls help
    im not shure what is cvar
    i paste this comand in my server.cfg
    sm_unfreezebots
    sb_all_bot_team
    but still not work
    [IMG]http://img405.**************/img405/4005/fullerrorversus.jpg[/IMG]

    Last edited by le0n_; 01-25-2011 at 05:38.
    le0n_ is offline
    Pescoxa
    Member
    Join Date: Dec 2009
    Old 02-03-2011 , 11:41   Re: [L4D/L4D2] VS Bug Fix
    Reply With Quote #6

    Quote:
    Originally Posted by [email protected] Rasta View Post
    Have error (((
    Code:
    L 01/03/2011 - 22:30:54: [SM] Native "SetConVarInt" reported: Invalid convar handle 0 (error 4)
    L 01/03/2011 - 22:30:54: [SM] Displaying call stack trace for plugin "l4d_sm_vsbugfix.smx":
    L 01/03/2011 - 22:30:54: [SM]   [0]  Line 73, l4d_sm_vsbugfix.sp::Init()
    L 01/03/2011 - 22:30:54: [SM]   [1]  Line 296, l4d_sm_vsbugfix.sp::Event_Round_Start()
    I've translated l4d_sm_vsbugfix.phrases.txt to Russian. Here it is:

    Code:
    "Phrases"
    {
    	//""Normal \x01 
    	//""Verde \x03 
    	//""Amarelo \x04 
    	//""Verde \x05
    	
    	"BOTsAreUnfrozen"
    	{
    		"en"		"BOTs are unfrozen."
    		"pt"		"BOTs estão descongelados."
    		"ru"		"БОТы разморожены."
    	}
    	
    	"GodOn"
    	{
    		"en"		"You had God Mode turned on."
    		"pt"		"Você teve o modo Deus ativado."
    		"ru"		"Вы включили режим Бога."
    	}
    	
    	"GodOff"
    	{
    		"en"		"You had God Mode turned off."
    		"pt"		"Você teve o modo Deus desativado."
    		"ru"		"Вы отключили режим Бога."
    	}
    	
    }
    The error is in the line:

    SetConVarInt(FindConVar("sb_all_bot_team"), 0);

    That means:

    FindConVar("sb_all_bot_team") returned 0.

    Possible cause:

    L4D/L4D2 ConVar "sb_all_bot_team" doesn't exist anymore in newer versions of the game.

    Possible solution:

    Just comment this line (with "//") and other with the same ConVar "sb_all_bot_team" or try to find a new ConVar that does the same thing.

    I can't fix it for now...
    Pescoxa is offline
    Pescoxa
    Member
    Join Date: Dec 2009
    Old 02-03-2011 , 11:48   Re: [L4D/L4D2] VS Bug Fix
    Reply With Quote #7

    Quote:
    Originally Posted by le0n_ View Post
    this not work on me
    pls help
    im not shure what is cvar
    i paste this comand in my server.cfg
    sm_unfreezebots
    sb_all_bot_team
    but still not work
    [IMG]http://img405.**************/img405/4005/fullerrorversus.jpg[/IMG]
    You don't have to change your server.cfg

    sm_unfreezebots is a command that you can run in console typing "sm_unfreezebots" or in the chat window typing "!unfreezebots". You need to be a server admin to run this command. If you can run "sm_admin" or "!admin", you can run "sm_unfreezebots".

    This plugin freezes all bots while you are in the safe area... If you left it, game runs as defaults, but closing if there's only one team in game.
    Pescoxa is offline
    Silvers
    AlliedModders Donor
    Join Date: Aug 2010
    Location: Space
    Old 02-03-2011 , 14:07   Re: [L4D/L4D2] VS Bug Fix
    Reply With Quote #8

    Pescoxa: did you even read is reply or screenshot?

    sb_all_bot_team is no longer valid in L4D2 it's been changed to sb_all_bot_game thats why it's not working.
    __________________
    Silvers is offline
    Pescoxa
    Member
    Join Date: Dec 2009
    Old 02-03-2011 , 15:01   Re: [L4D/L4D2] VS Bug Fix
    Reply With Quote #9

    Silvers:

    What did you mean?

    I'll change the source code...
    Pescoxa is offline
    Silvers
    AlliedModders Donor
    Join Date: Aug 2010
    Location: Space
    Old 02-03-2011 , 15:21   Re: [L4D/L4D2] VS Bug Fix
    Reply With Quote #10

    sb_all_bot_team - Works as normal for L4D1.
    sb_all_bot_game - Is the new command for L4D2 (since the above was removed by Valve due to some bugs)
    __________________
    Silvers is offline
    Reply


    Thread Tools
    Display Modes

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off

    Forum Jump


    All times are GMT -4. The time now is 01:57.


    Powered by vBulletin®
    Copyright ©2000 - 2017, vBulletin Solutions, Inc.
    Theme made by Freecode