Raised This Month: $134 Target: $400
 33% 

[EXTENSION] Left 4 Downtown (0.4.6) - L4D2 is here and supported


Post New Thread Reply   
 
Thread Tools Display Modes
RasterMan
Senior Member
Join Date: Mar 2004
Location: Luton, UK
Old 04-27-2010 , 12:40   Re: [EXTENSION] Left 4 Downtown (0.4.6) - L4D2 is here and supported
Reply With Quote #851

Just updated my linux server with the valve's update today and the new gamedata doesn't work now!

The server is acting as if it's full but it's empty...

Error:

L 04/26/2010 - 17:26:53: [LEFT4DOWNTOWN] PlayerSlots -- Offset for 'ValveRejectServerFullFirst' is incorrect
__________________

Last edited by RasterMan; 04-27-2010 at 12:53. Reason: I'm a muppet :)
RasterMan is offline
Send a message via MSN to RasterMan
psychonic

BAFFLED
Join Date: May 2008
Old 04-27-2010 , 13:01   Re: [EXTENSION] Left 4 Downtown (0.4.6) - L4D2 is here and supported
Reply With Quote #852

The Passing DLC info Post
(as linked from the first post)
New binaries compiled from The Passing are attached to this post. This is AtomicStryker's version 0.4.7.
If you already have the working versions of these from prior posts, you do not need to redownload them.

These will run on any SM/MM version that L4D2 supports (sm1.3+/mm1.8+).

Live gamedata link (will always be newest I have):
http://left4downtown2.googlecode.com...ntown.l4d2.txt

Current known issues:
(none)


Attached Files
File Type: zip left4downtown_passingfix.zip (154.1 KB, 1512 views)

Last edited by psychonic; 04-27-2010 at 14:39. Reason: fixed ValveRejectServerFullFirst offset on windows
psychonic is offline
psychonic

BAFFLED
Join Date: May 2008
Old 04-27-2010 , 13:04   Re: [EXTENSION] Left 4 Downtown (0.4.6) - L4D2 is here and supported
Reply With Quote #853

Quote:
Originally Posted by RasterMan View Post
Just updated my linux server with the valve's update today and the new gamedata doesn't work now!

The server is acting as if it's full but it's empty...

Error:

L 04/26/2010 - 17:26:53: [LEFT4DOWNTOWN] PlayerSlots -- Offset for 'ValveRejectServerFullFirst' is incorrect
I'll check it out
psychonic is offline
basktfbb
Member
Join Date: Feb 2010
Old 04-27-2010 , 13:12   Re: [EXTENSION] Left 4 Downtown (0.4.6) - L4D2 is here and supported
Reply With Quote #854

how do I display 9 slots in the lobby?
in "openserverbrowser" it shows 0/9 slots
but in the lobby only 0/8
Attached Thumbnails
Click image for larger version

Name:	lobby.jpg
Views:	405
Size:	80.5 KB
ID:	64486   Click image for larger version

Name:	OperServer.jpg
Views:	481
Size:	23.7 KB
ID:	64487  
basktfbb is offline
psychonic

BAFFLED
Join Date: May 2008
Old 04-27-2010 , 13:44   Re: [EXTENSION] Left 4 Downtown (0.4.6) - L4D2 is here and supported
Reply With Quote #855

Quote:
Originally Posted by RasterMan View Post
Just updated my linux server with the valve's update today and the new gamedata doesn't work now!

The server is acting as if it's full but it's empty...

Error:

L 04/26/2010 - 17:26:53: [LEFT4DOWNTOWN] PlayerSlots -- Offset for 'ValveRejectServerFullFirst' is incorrect
Make sure you are using the newest gamedata. Even after yesterday's update, I can still change l4d_maxplayers on linux without that error.
psychonic is offline
RasterMan
Senior Member
Join Date: Mar 2004
Location: Luton, UK
Old 04-27-2010 , 13:59   Re: [EXTENSION] Left 4 Downtown (0.4.6) - L4D2 is here and supported
Reply With Quote #856

Am using the latest m8
My Linux server still won't let anyone join it says full when it's empty

I can change the max players no problems just nobody can join...
__________________
RasterMan is offline
Send a message via MSN to RasterMan
biship
Member
Join Date: Dec 2009
Old 04-27-2010 , 14:02   Re: [EXTENSION] Left 4 Downtown (0.4.6) - L4D2 is here and supported
Reply With Quote #857

I get this as soon as I start my windows server, even with the updates from post #852:

L 04/27/2010 - 12:56:40: SourceMod error session started
L 04/27/2010 - 12:56:40: Info (map "c1m1_hotel") (file "errors_20100427.log")
L 04/27/2010 - 12:56:40: [LEFT4DOWNTOWN] PlayerSlots -- Offset for 'ValveRejectServerFullFirst' is incorrect

On command line I have +maxplayers 9
I do not set l4d_maxplayers (as I have never had too).
biship is offline
RasterMan
Senior Member
Join Date: Mar 2004
Location: Luton, UK
Old 04-27-2010 , 14:05   Re: [EXTENSION] Left 4 Downtown (0.4.6) - L4D2 is here and supported
Reply With Quote #858

@biship

This is what we are trying to sort out....
__________________
RasterMan is offline
Send a message via MSN to RasterMan
psychonic

BAFFLED
Join Date: May 2008
Old 04-27-2010 , 14:21   Re: [EXTENSION] Left 4 Downtown (0.4.6) - L4D2 is here and supported
Reply With Quote #859

Quote:
Originally Posted by RasterMan View Post
Am using the latest m8
My Linux server still won't let anyone join it says full when it's empty

I can change the max players no problems just nobody can join...
I still can't replicate the error you're getting. I made sure the server was up to date and tried it both via commandline and cvar.

Code:
[[email protected] ~]$ ./steam -command update -game left4dead2 -dir l4d2 -verify_all
Checking bootstrapper version ...
Updating Installation
Checking/Installing 'left 4 dead 2 common' version 24


Checking/Installing 'left 4 dead 2 linux dedicated server' version 19


Checking/Installing 'Left 4 Dead 2 Add-on Support' version 6


HLDS installation up to date
[[email protected] ~]$ cd l4d2/left4dead2/
[[email protected] left4dead2]$ ./srcds_run +map c1m1_hotel +maxplayers 16
Server will auto-restart if there is a crash.
Running a benchmark to measure system clock frequency...
Finished RDTSC test. To prevent the startup delay from this benchmark, set the environment variable RDTSC_FREQUENCY to 2266.000000 on this system. This value is dependent upon the CPU clock speed and architecture and should be determined separately for each server. The use of this mechanism for timing can be disabled by setting RDTSC_FREQUENCY to 'disabled'.
#
#Console initialized.
#Game.dll loaded for "Left 4 Dead 2"
Server is hibernating
ConVarRef test_progression_loop doesn't point to an existing ConVar
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
Parent cvar in server.dll not allowed (spit_scaling_min_scale)
Game supporting (2) split screen players
maxplayers set to 18
maxplayers set to 18
Unknown command "mat_bloom_scalefactor_scalar"
Network: IP 74.121.182.167, mode MP, dedicated Yes, ports 27015 SV / 0 CL
---- Host_NewGame ----
Host_NewGame on map c1m1_hotel
L 04/27/2010 - 21:12:43: -------- Mapchange to c1m1_hotel --------
ConVarRef room_type doesn't point to an existing ConVar
Executing dedicated server config file
Initializing Director's script
Couldn't find any entities named fire13_timer, which point_template fire13_template is specifying.
Couldn't find any entities named fire13_clip, which point_template fire13_template is specifying.
Couldn't find any entities named fire13_smoke, which point_template fire13_template is specifying.
Couldn't find any entities named fire13_fog_volume, which point_template fire13_template is specifying.
Couldn't find any entities named fire14_timer, which point_template fire14_template is specifying.
Couldn't find any entities named fire14_clip, which point_template fire14_template is specifying.
Couldn't find any entities named fire14_smoke, which point_template fire14_template is specifying.
Couldn't find any entities named fire14_fog_volume, which point_template fire14_template is specifying.
Couldn't find any entities named fire15_timer, which point_template fire15_template is specifying.
Couldn't find any entities named fire15_clip, which point_template fire15_template is specifying.
Couldn't find any entities named fire15_smoke, which point_template fire15_template is specifying.
Couldn't find any entities named fire15_fog_volume, which point_template fire15_template is specifying.
Couldn't find any entities named fire16_timer, which point_template fire16_template is specifying.
Couldn't find any entities named fire16_clip, which point_template fire16_template is specifying.
Couldn't find any entities named fire16_smoke, which point_template fire16_template is specifying.
Couldn't find any entities named fire16_fog_volume, which point_template fire16_template is specifying.
Couldn't find any entities named sound, which point_template fire_ballroom_07-template is specifying.
Couldn't find any entities named fire03-sound, which point_template fire03-template is specifying.
Couldn't find any entities named fire04-sound, which point_template fire04-template is specifying.
Couldn't find any entities named fire10-sound, which point_template fire10-template is specifying.
Couldn't find any entities named fire27-sound, which point_template fire27-template is specifying.
Couldn't find any entities named fire28-sound, which point_template fire28-template is specifying.
Couldn't find any entities named fire_ballroom_02-sound, which point_template fire_ballroom_02-template is specifying.
Couldn't find any entities named fire_ballroom_01-sound, which point_template fire_ballroom_01-template is specifying.
Couldn't find any entities named fire_ballroom_03-sound, which point_template fire_ballroom_03-template is specifying.
Couldn't find any entities named fire_ballroom_04-sound, which point_template fire_ballroom_04-template is specifying.
Couldn't find any entities named fire_ballroom_05-sound, which point_template fire_ballroom_05-template is specifying.
Couldn't find any entities named fire_ballroom_06-sound, which point_template fire_ballroom_06-template is specifying.
Couldn't find any entities named fire_ballroom_07-particles, which point_template fire_ballroom_07-template is specifying.
Couldn't find any entities named fire_ballroom_07-point1, which point_template fire_ballroom_07-template is specifying.
Couldn't find any entities named fire_ballroom_07-point3, which point_template fire_ballroom_07-template is specifying.
Couldn't find any entities named fire_ballroom_07-point5, which point_template fire_ballroom_07-template is specifying.
Couldn't find any entities named fire_ballroom_07-point6, which point_template fire_ballroom_07-template is specifying.
Couldn't find any entities named fire_ballroom_07-hurt, which point_template fire_ballroom_07-template is specifying.
Couldn't find any entities named fire_ballroom_07-sound, which point_template fire_ballroom_07-template is specifying.
Couldn't find any entities named fire_ballroom_08-sound, which point_template fire_ballroom_08-template is specifying.
Couldn't find any entities named fire_ballroom_09-sound, which point_template fire_ballroom_09-template is specifying.
Couldn't find any entities named fire_ballroom_10-sound, which point_template fire_ballroom_10-template is specifying.
Couldn't find any entities named fire_ballroom_11-sound, which point_template fire_ballroom_11-template is specifying.
Couldn't find any entities named inferno02-sound, which point_template inferno02-template is specifying.
prop_door_rotating has Door model (models/props_downtown/metal_door_112_dm03_01.mdl) with no door_options! Verify that SKIN is valid, and has a corresponding options block in the model QC file
prop_door_rotating has Door model (models/props_downtown/metal_door_112_dm03_01.mdl) with no door_options! Verify that SKIN is valid, and has a corresponding options block in the model QC file
WARNING: orator at 454 5671 2684 missing modelname
Attempting to precache model, but model name is NULL
Commentary: Loading commentary data from maps/c1m1_hotel_commentary.txt.
Initializing Director's script
[S_API FAIL] SteamAPI_Init() failed; unable to update local steamclient.dll. Continuing with current version anyway.
exec: couldn't exec server.cfg
exec: couldn't exec sourcemod/sourcemod.cfg
Connection to Steam servers successful.
   VAC secure mode is activated.

l4d_maxplayers 18

Last edited by psychonic; 04-27-2010 at 14:32.
psychonic is offline
RasterMan
Senior Member
Join Date: Mar 2004
Location: Luton, UK
Old 04-27-2010 , 14:28   Re: [EXTENSION] Left 4 Downtown (0.4.6) - L4D2 is here and supported
Reply With Quote #860

I've just reinstalled the whole server from scratch! (Might have been a bad valve update)
I've got rid of the error message now by installing all what you posted again but nobody can join the server it still says full when you try to join!
__________________
RasterMan is offline
Send a message via MSN to RasterMan
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:20.


Powered by vBulletin®
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Theme made by Freecode