View Single Post
Junior Member
Join Date: Mar 2019
Old 09-02-2019 , 08:02   Re: Bug from Metamod
Reply With Quote #3


Sorry for bumping this thread but I got the same error coming up today on Windows. I tried reinstalling my csgo dedicated server. It launches well without sourcemod / metamod but when I add the sourcemod and metamod files in the csgo folder, I get the error: "Missing shutdown function for sv.Init( bDedicated ) : sv.Shutdown()" when starting the server.

Sourcemod version: 1.9 - build 6281
Metamod version: 1.10 - build 970

What is even more strange is that it was working last week and it does not seem that there were any updates this weekend. I even have Linux servers working normally today.

EDIT: So I have been looking more in details at the error and more specifically at the .mdmp file created by this crash and here is the output:
Dump File: srcds_2117156_crash_2019_9_2T13_1_27C0.mdmp : C:\csgo-ds\srcds_2117156_crash_2019_9_2T13_1_27C0.mdm p
Last Write Time: 02.09.2019 15:01:27
Process Name: srcds.exe : C:\csgo-ds\srcds.exe
Process Architecture: x86
Exception Code: 0xC0000005
Exception Information: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
Heap Information: Not Present

Still don't know how to solve this but it seems that it is an access error...
Let me know if you have any idea.

Last edited by almil36; 09-02-2019 at 09:36. Reason: Adding information
almil36 is offline