View Single Post
AlliedModders Donor
Join Date: Jan 2011
Old 09-05-2017 , 17:48   Re: L4D/L4D2 Tickrate Enabler
Reply With Quote #8

Originally Posted by Skorpyo View Post
plugins_print wasn't doing anything so I could only assume that it was related to the sm plugin list. fps_max changing works just fine, however the updaterate and cmdrate changes, despite saying they were changed server side, do nothing. I can see now, that it was a typo, and that "plugin_print" is the correct console command. The only thing that shows up for me is metamod source. The same result happens on a PC that I have direct access to, to confirm the dll is installed. It just behaves as if the tickrate enabler is not there at all. Does the version of metamod source installed have anything to do with it?

For reference, I tried the exact settings listed in the post. and also with sm_cvar in front of them. also tried -tickrate 60 in the command line with matching cfg settings. The vdf and dll are in the addons folder like stated. I could have missed a crucial step, but I don't see it.
The Metamod version should not matter. You don't actually even need to have MM:S installed to load it. Since it isn't being loaded, my guess is the files aren't installed in the correct locations.

Make sure you have tickrate_enabler_l4d1.vdf in your addons folder. If you placed it inside your metamod folder, move it out of there and put it back into the base addons folder where the metamod.vdf file is.

The way the vdf is set up, the tickrate_enabler.dll file must be in a subdirectory of addons named tickrate_enabler.

Double-check both of those files and see if it fixes the problem.
epzminion is offline