View Single Post
Author Message
Dr. Jekyll
Member
Join Date: Sep 2015
Old 09-18-2015 , 05:44   Metamod not loading on my TF2 dedicated server
Reply With Quote #1

Hi,

I cannot seem to get metamod to run on my TF2 server. I've installed the dedicated server correctly (it runs and I can join it, although it can't be joined through it's public IP by myself or my friends). I downloaded the latest version and extracted it to C:\hlserver\tf2 and it shows up in the addons, with all the appropriate files.

But when I start the server and type "meta version" into the server console, it says Unknown Command "meta". I tried replacing the vdf file with one customized for TF2 (from the metamod site), but that didn't help. I've also tried updating the server with the "steamcmd.exe" tool, which tells me that the game is already updated.

I followed the instructions on installing metamod from this page very carefully.

I'm guessing there is something very simple that I'm not doing right, but I can't figure out what it is. Any suggestions?
Dr. Jekyll is offline