View Single Post
rogueactivex
New Member
Join Date: Jan 2017
Old 01-12-2017 , 18:37   Re: [CS:S] Server crashes on spawn
Reply With Quote #4

I have the same problem. Here are the steps I've followed:

Followed instructions to download metamod, sourcemod, CSS server and CS Deathmatch mod:

mmsource-1.10.6-windows.zip
sourcemod-1.8.0-git5967-windows.zip
cssdm-2.1.6-hg197-windows.zip (using the latest version I could find)

Followed steps 1-5 to download the CS server:
https://steamcommunity.com/sharedfil.../?id=397365275

Followed instructions to unzip metamod to CSS/cstrike addon files.

Started server using shortcut, run as administrator, using these parameters in the shortcut:

"C:\steamcmd\CSS\srcds.exe" -console -game cstrike +maxplayers 32 +map de_dust2

I then open up my CS game from Steam, join the server, can type meta version in the console. I see that metamod is installed and running, so I exit and follow the instructions to unzip the sourcemod.

After copying the files into the cstrike folder, I restarted the server, join it from CS, and run these commands:

] meta version
Compiled on: Sep 10 2015
Metamod:Source version 1.10.6
Plugin interface version: 15:14
SourceHook version: 5:5
http://www.metamodsource.net/
] meta list
[01] SourceMod (1.8.0.5967) by AlliedModders LLC
[02] CS Tools (1.8.0.5967) by AlliedModders LLC
[03] SDK Tools (1.8.0.5967) by AlliedModders LLC


] sm
SourceMod 1.8.0.5967, by AlliedModders LLC
To see running plugins, type "sm plugins"
To see credits, type "sm credits"
Visit http://www.sourcemod.net/

Add in my Steam ID, which I collected by putting my profile URL in this link:
http://steamidfinder.com/

File I'm adding to: /addons/sourcemod/configs/admins_simple.ini

"STEAM_0:0:[truncated]" "99:z"

Then I restarted the CS server.

During play I could run sm_admin and also bind it to a key.

After that I copied the CSM mod files to the /cstrike folder.

Restarted the server and rejoined it.

Upon trying to join a team it crashes upon spawn.

I reloaded the server and client again, but this time would play.

But when I attempted to add a bot using bot_add 1, and the slayed myself (to restart the round and allow the bot to spawn), it crashed.

I am running the shortcut as administrator within Windows 10 and I also removed the read-only permission from all files and folders.

Any thoughts?
rogueactivex is offline