View Single Post
Junior Member
Join Date: Oct 2013
Old 03-20-2019 , 11:45   Re: Source Dedicated Server for Mac OS X
Reply With Quote #223

Having a major issue, and I can't figure out what's wrong.
Initially it was saying "Missing gameinfo.txt", so I added -game tf to the command line, but it still shows up with the same error when I have gameinfo.txt inside tf. I changed the -game to +game, tried different things, nothing worked, except for placing a copy of gameinfo.txt inside the server root folder.

Then....after that, I've got this problem now. What could be wrong?

Wed Mar 20 22:423 +08 2019: Server restart in 10 seconds
Checking for Steam library update...
Installed version: 1550534751
Latest version: 1550534751
Verifying installation...
No Steam library update required
Warning: falling back to auto detection of vproject directory.
Setting breakpad minidump AppID = 440
Steam_SetMinidumpSteamID: Caching Steam ID: 76561198084450756 [API loaded no]
Timed out waiting for game mapping!
Did not detect any valid joysticks.
Requested non-existent write path GAME!
Requested non-existent write path GAME!

Console initialized.
./ line 418: 5032 Segmentation fault: 11 $HL_CMD
Add "-debug" to the ./ command line to generate a debug.log to help with solving this problem
Wed Mar 20 22:42:51 +08 2019: Server restart in 10 seconds
Legendoniance is offline