View Single Post
myljach
Junior Member
Join Date: Jul 2016
Old 11-16-2019 , 11:45   Re: sourcebans++ error
Reply With Quote #5

Quote:
Originally Posted by DruGzOG View Post
How'd you go about doing this? I'm having the same issue with the latest build of sm
I was first have problem with properly installing LAMP (Apache, mysql, php), mysql ws not running, later i find reason was - missing libraries.
After that i finish install sourcebans++, web page was fine and without errors, but when i test ban my account, and acc was in ban list, i was still able to connect in server. Issue was - no connection between sourcebans and mysql. Then i was have error from my 1st opening post, and issue for that message was old sourcebans files and configurations, because in old configuration i was copy paste old files in backup folders and start all over not from pay-to-host, i use machine 24/7 intel nuc (enough for source servers) and old files stay. i build up like all from scratch and mix files from old servers (modded versus l4d2 and coop).
After remove old plugin sourcebans.smx, in sourcebans++ take ower new files sbpp****.smx but i was have other error message.
I figure out that problem is between sourcebans, mysql, and sourcemod, where sourcebans like to see socket under /var/run/mysqld/mysqld.sock, and sourcemod under /tmp/mysql.sock, so to connect them is needed symlink ( https://stackoverflow.com/questions/...-file-in-linux )
After i lift up on one server to work, (ban in game work, add to sourcebans, admin panel work, add to sourcebans, RMB live player option kick, ban, send message still not work for now), i copy paste files to other 2 servers.
In one server all works like in 1st, and in third server still not. Ban is in sourcebans, in 2 server says im banned, in 3th same but i may connect. In setup server from web is all fine, Id of server is same as in sourcebans.cfg edited file. I was do same as in 2 servers and 3th not work.
In log file is no error message, but if i reload plugin in terminal with sm plugins reload 80(number of plugin) i got message - SM plugin fail to reload sbpp_main.smx -
i check same files in other servers under addons/sourcemod/plugins and all looks same, all sbpp plugin same size.
Problem where i will look for that may be different versions of sourcemods, 1 server use v9.***, other use developer version v10.****
since i have lot of plugins, and somewhere different version of sourcemod, metamod, L4ddowntown (i try developer only for mutant tanks plugin-120 different tank models), and still there may be issue with setup servers in sourcebans in groups, rcon pass etc
And in that mess is hard to know where to search. For example, i was have issue here : https://forums.alliedmods.net/showthread.php?t=316512
i solve problem my type when start server -nowatcdog to disable server restart if crash, because server restart in loop occasionally, more frequent if i load in server more custom maps (i host now like 140+). Problem is - server take more time to load, watchdog think is stuck, and restart server. when i find time i will try find where i can expand time of watchdog. My point is, nowhere i find discussion about that.
Now i relax my soul to some stranger over internet
I hope i find why my 3th server not accept plugin sbpp_main.smx
my sourceban: http://myljach.mooo.com/
gametracker: https://www.gametracker.com/search/?query=myljach

I hope u find something useful in my respond
myljach is offline