View Single Post
xucian
Junior Member
Join Date: Dec 2019
Location: Bucharest
Old 12-30-2019 , 04:30   Re: Development Roundup, We need you!
Reply With Quote #73

Quote:
Originally Posted by Arkshine View Post
The newline in `client_cmd` has always been there from the start. Maybe with the recent game releases, it's no more needed.
Are you using the latest HLDS version or ReHLDS?
Also, before anything else, make sure you do pass a valid command and that you can reproduce (create a simple test plugin, if you can)

If you are sure there is an issue and you're using HLDS, you should create an issue on Github.
Thanks for replying!
HLDS for the moment.

But I just found out this morning (by hopelessly trying different things) that mp3 play <anything that doesn't start with "media/"> shows the invalid command message.
Is this intended or should I submit a bug report somewhere?

I see most of the online references for playing mp3s on clients use sound/....mp3 and media/....mp3 interchangeably, but I guess something changed in HLDS, or new dlls on clients

UPDATE: Actually, I think the client or server's dll blocks paths containing certain words. For example, it would tell Invalid command for media/somename/loading/1.mp3 but not for media/somename/loaging/1.mp3 - I don't understand. Should I create an issue about this on github?
UPDATE2: Done
__________________

Play with us: Zp.TheFallenGames.Com #InConstruction

Last edited by xucian; 01-02-2020 at 12:17.
xucian is offline
Send a message via Skype™ to xucian