Thread: [Solved] HLDS not responding
View Single Post
Author Message
New Member
Join Date: Sep 2020
Old 09-15-2020 , 15:25   HLDS not responding
Reply With Quote #1


I am trying to run a HLDS server (CS 1.6), no mods, no addons, completely stock, following these instructions: I have tried installing on CentOS 7, Ubuntu 18.04 and Ubuntu 20.04. All was fine a few days ago, but now, after startup, I can't type anything into server console and the server is not responding.

Here is the startup command I use:
./hlds_run -autoupdate -game cstrike +map de_dust2 +maxplayers 10
And here is the output:
Auto-restarting the server on crash
Could not locate steam binary:steamcmd/, ignoring.

Console initialized.
Using breakpad crash handler
Setting breakpad minidump AppID = 10
Forcing breakpad minidump interfaces to load
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Protocol version 48
Exe version (cstrike)
Exe build: 19:52:19 Aug  3 2020 (8684)
STEAM Auth Server
Server IP address
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
with error: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
FATAL ERROR (shutting down): Unable to initialize Steam.
Linking as described here, does not resolve the issue.
I am out of ideas

When I start HLDS without specifying map, it works. As soon as I run map command the console is stuck and I can't type anything.

Solved by linking in /usr/lib

Last edited by mentesh; 09-16-2020 at 09:03. Reason: Solved
mentesh is offline