View Single Post
Author Message
CrazyKermitRubes
Junior Member
Join Date: Sep 2020
Old 09-11-2020 , 12:57   [SOLVED] E997 or TRCON: Cannot setup TCP socket ...... Connection refused.
Reply With Quote #1

Hello,
I am using the latest HLstatsx:CE on CentOS 8. Running a TF2 server on port 27019.
Everything is residing on the same server.
I seem to be getting one of two errors in the log:
The E997 or TRCON: Cannot setup TCP socket ...... Connection refused.
I'm pretty sure this has something to do with the ports, but I cannot seem to get both resolved.

I tried setting everything to port 27500 except for public server address. That's when I get the E997: NOT ALLOWED SERVER error in the logs.

If I try setting the listener port in Edit Server from 27500 to 27019 (just bare with me a sec), I get TRCON: Cannot setup TCP socket ...... Connection refused instead of the E997 error, but everything gets logged to mysql. Commands like rank etc do not yet work, though.

I cannot seem to make both errors go away.

Ports 27019 and 27500 are both open for TCP and UDP traffic on firewalld (for now).

Settings:
log on
logaddress_list: 1 entry
serverip:27500

hlstats.conf:
DBHost: serverip

BindIP ""

Port 27500


Edit Server settings on web:
IP address - serverip port - 27500; public address - serverip:27019
If I change that port from 27500 to 27019 I get that TRCON error.

Daemon control on web is set to localhost and the port is set to 27500

I have tried looking at numerous posts with similar issues, but none of given solutions seem to work.
All of the perl scripts have execute permissions already.

Any idea what settings I should be changing so that it actually works?

So the captcha wouldn't let me reply to my post (was broken - I must be a robot).
Solution: the listener port in web should be set to the public port? Also, +ip 0.0.0.0 needed to be added as an argument to server startup. Not sure how that would work with hosting things on different ips, though.

Last edited by CrazyKermitRubes; 09-21-2020 at 23:58. Reason: solved
CrazyKermitRubes is offline