View Single Post
Author Message
Join Date: Feb 2008
Location: Street
Old 02-28-2017 , 02:40   mm_basedir and sm_basepath issue
Reply With Quote #1


First of all sorry for my bad English

Main issue, I can't load metamod and sourcemod.

I'm trying run 2 seperate servers from the same csgo instaliation, but it's look that I'm too big noob to do this, so maybe someone can help me with this.

What I'm doing and what I have:

I have 1 CS:GO instaliation

I have 2 seperated metamod:source directories (mm_public and mm_jail) boths directories look like:


In these directories I have (just say in mm_public):

2 directories:
metamod and sourcemod
and 1 file: metamod.vdf

metamod.vdf file content:

"file" "addons/mm_public/metamod/bin/server"
in metamod directory have 1 file and 1 directory:

Dir: bin
File: sourcemod.vdf

sourcemod.vdf file content:
"Metamod Plugin"
"alias" "public"
"file" "addons/mm_public/sourcemod/bin/sourcemod_mm"

It's look everything ok, but Metamod and Sourcemod is not loaded.

I tried add cvars in [ROOT]/cfg/public-server.cfg file (this file really working and other cvars changing):

mm_basedir "addons/mm_public/metamod"
sm_basepath "addons/mm_public/sourcemod"

Also tried to add these cvars as command line options:

./srcds_run -game csgo +mm_basedir addons/mm_public/metamod +sm_basepath addons/mm_public/sourcemod

Nothing happend, server running, but then I trying in console: meta get answer:

Unknown command "meta"
How I understand, metamod was not loaded. Same with command sm

Can anyone help me with this. I'm stuck for 2 days now

Last edited by Min2liz; 02-28-2017 at 04:07.
Min2liz is offline