AlliedModders

AlliedModders (https://forums.alliedmods.net/index.php)
-   HLstatsX:CE (https://forums.alliedmods.net/forumdisplay.php?f=156)
-   -   [SOLVED]HLstatsX wont load player profile (https://forums.alliedmods.net/showthread.php?t=203052)

Eska 12-14-2012 09:20

[SOLVED]HLstatsX wont load player profile
 
Well, i dont know where to grab that issue.
Everything works, deamon running and connected to DB, hlstatsx shows serwer status and if there are players, i also can see them, but when i try enter to some player profile, like:

http://hlstatsx.skillfactory.pl/hlst...rinfo&player=1

It just says Loading... and nothing more.

http://hlstatsx.skillfactory.pl/hlst...chat&game=csgo click any name from chat,
Profile wont load.

Any ideas ?

Code:

[email protected]:~/hlstatsx/scripts$ ./run_hlstats restart

HLstatsX:CE daemon control
http://www.hlxce.com
---------------------------
Attempting graceful shutdown of HLstatsX:CE daemon on port 27500  1
Attempting to start HLstatsX:CE daemon on port 27500...
Daemon successfully restarted on port 27500

And no errors in game console

And awards page goes blank: http://hlstatsx.skillfactory.pl/hlst...ards&game=csgo
But actions seems to work: http://hlstatsx.skillfactory.pl/hlst...ions&game=csgo

On the server there wasnt alot players.

note: HLstatsX+Database is on other machine than GameServer

And i see in database in hlstatsx_Players that THERE ARE infos about profiles inserted into MySQL.

Any clue why ? What i may doing wrong ?

Eska 12-14-2012 16:29

Re: HLstatsX wont load player profile
 
Just tried this hotfix from here :

Quote:

Originally Posted by Mavrick4283 (Post 1852512)
Please apply the CSGO hotfix downloaded here https://bitbucket.org/psychonic/hlstatsxce/downloads

You need to STOP the damon apply the new file, make it exec (chmod +x) then start the damon back up.

Let me know if that does fix it.

@knorde I looked at your web install of HLX it looks like it is missing ALOT of files or has been modded. If this patch does not fix your problem you might need to install HLX:CE fresh (including the DB)


But still same. Anyone ?

How i can recall some debug option to see where problem is placed here ?

SanKen 12-14-2012 16:50

Re: HLstatsX wont load player profile
 
The problem lies with the hosting. Check on another hosting.

Mavrick4283 12-14-2012 16:55

Re: HLstatsX wont load player profile
 
The problem is not with the host, i am guessing that he applyed the hot fix wrong because

Quote:

Tracking 74 players (+20 new players last 24h) with 0 kills (+-1 last 24h) and 0 headshots (0.00%) on 1 servers
The DB is still not getting the kills logged.

Eska 12-14-2012 16:58

Re: HLstatsX wont load player profile
 
Quote:

Originally Posted by Mavrick4283 (Post 1853832)
The problem is not with the host, i am guessing that he applyed the hot fix wrong because



The DB is still not getting the kills logged.

Let me check again. If i just kill bots, he will log it as kills or i need to get real players ?

Mavrick4283 12-14-2012 17:02

Re: HLstatsX wont load player profile
 
you need to go to admin -> game -> server config -> and turn ignore bots to 0

Eska 12-14-2012 17:06

Re: HLstatsX wont load player profile
 
Quote:

Originally Posted by Mavrick4283 (Post 1853839)
you need to go to admin -> game -> server config -> and turn ignore bots to 0

Ok, will check in a sec, i might just done something wrong with hotfix. Thanks for fast reply

Eska 12-14-2012 17:29

Re: HLstatsX wont load player profile
 
Tracking 74 players (+20 new players last 24h) with 2 kills (+-1 last 24h) and 1 headshots (50.00%) on 1 servers

Ok, works now.

Still not loading profiles.
link: http://hlstatsx.skillfactory.pl/hlst...rinfo&player=1
Awards goes to blank:
http://hlstatsx.skillfactory.pl/hlst...ards&game=csgo

and:


Code:

(...)
2012-12-15 01:21:08:  91.231.140.105:27015 - DEBUG: Updated IP for 73 to 94.170.116.34
2012-12-15 01:21:08:  91.231.140.105:27015 - E001: "Crazy Frog" <P:73,U:10,W:1:12296117,T:> connected, address "94.170.116.34", hostname "", hostgroup ""
2012-12-15 01:21:09:  91.231.140.105:27015 - E001: BAD DATA: "Crazy Frog<10><STEAM_1:1:12296117><>" STEAM USERID validated
2012-12-15 01:21:19:  91.231.140.105:27015 - MYSQL: Flushing player updates to database...
2012-12-15 01:21:20:  91.231.140.105:27015 - MYSQL: Flushing player updates to database is complete.
2012-12-15 01:21:23:  91.231.140.105:27015 - E008: (IGNORED) NOTMINPLAYERS: "Cliffe" <P:51,U:3,W:BOT:94690bdaa6704d7dd7bec930bb33992e,T:TERRORIST> killed "Gunner" <P:52,U:7,W:BOT:55a775a603e9ea4f3f7016318b28a30c,T:CT> with "ak47"
2012-12-15 01:21:24:  91.231.140.105:27015 - DNS: Resolving hostname (timeout 3 sec) for IP "94.170.116.34" - cpc1-dals15-2-0-cust33.hari.cable.virginmedia.com
2012-12-15 01:21:24:  91.231.140.105:27015 - E002: "Crazy Frog" <P:73,U:10,W:1:12296117,T:> entered the game
(...)
2012-12-15 01:22:11:  91.231.140.105:27015 - E020: (IGNORED) OK Rcon from "91.231.140.105": "hlx_sm_psay "10" "Crazy Frog got 2 points (1,002) for Pick up the Bomb""
2012-12-15 01:22:17:  91.231.140.105:27015 - E013: (IGNORED) World triggered "Round_Start" (7/4)
2012-12-15 01:22:38:  91.231.140.105:27015 - E008: "Quade" <P:42,U:8,W:BOT:bebef0bc4b048566024f61f1b73f92fb,T:TERRORIST> killed "Crusher" <P:41,U:5,W:BOT:0e4f86d24e6a105eb91fc86f1d3c8d76,T:CT> with "glock"
2012-12-15 01:22:39:  91.231.140.105:27015 - E020: (IGNORED) OK Rcon from "91.231.140.105": "status"
2012-12-15 01:22:39:  91.231.140.105:27015 - E020: BAD DATA: rcon from "91.231.140.105:47298": command ""
2012-12-15 01:22:39:  91.231.140.105:27015 - E020: (IGNORED) OK Rcon from "91.231.140.105": "sv_visiblemaxplayers"
2012-12-15 01:22:40:  91.231.140.105:27015 - E008: "Gunner" <P:52,U:7,W:BOT:55a775a603e9ea4f3f7016318b28a30c,T:CT> killed "Quade" <P:42,U:8,W:BOT:bebef0bc4b048566024f61f1b73f92fb,T:TERRORIST> with "hkp2000"
2012-12-15 01:22:40:  91.231.140.105:27015 - MYSQL: Flushing player updates to database...
2012-12-15 01:22:40:  91.231.140.105:27015 - MYSQL: Flushing player updates to database is complete.
(...)


Mavrick4283 12-14-2012 17:43

Re: HLstatsX wont load player profile
 
I do not know, what i can tell you is that your website is not generateing the links correctly IE.

Code:

http://hlstatsx.skillfactory.pl/hlstats.php?mode=playerinfo&player=1#
When it should be

Code:

http://hlstatsx.skillfactory.pl/hlstats.php?mode=playerinfo&player=1#general_aliases
So i would have to guess that it is a old version of PhP or the install is corrupted

Eska 12-14-2012 17:48

Re: HLstatsX wont load player profile
 
let me do phpinfo script


All times are GMT -4. The time now is 18:52.

Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.