AlliedModders

AlliedModders (https://forums.alliedmods.net/index.php)
-   Source Servers (SRCDS) (https://forums.alliedmods.net/forumdisplay.php?f=130)
-   -   [CS:GO] Nades are laggy (https://forums.alliedmods.net/showthread.php?t=333523)

Arad119 07-18-2021 14:53

[CS:GO] Nades are laggy
 
As the title states, nades become laggy after the server has been on for a while. Doesn't matter which map it is nor does it matter if the server pc is under heavier load or not. The server is running on a windows machine.

The issue gets temporarily fixed if I restart the server but reoccurs after waiting some time again.

Preview: Video Link

ThePwnt 07-18-2021 15:47

Re: [CS:GO] Nades are laggy
 
Does it still laggy, if you (for example) switch map after 10 minutes?

Arad119 07-18-2021 20:01

Re: [CS:GO] Nades are laggy
 
Quote:

Originally Posted by ThePwnt (Post 2753098)
Does it still laggy, if you (for example) switch map after 10 minutes?

Yes, the nades are still lagging even if I change the map. The nades end up at the exact same place as if it was not lagging, the only difference is that the nades look laggy mid-air.

Bacardi 07-18-2021 20:26

Re: [CS:GO] Nades are laggy
 
Enable net_graph 5 in your game.

In server sv_max_allowed_net_graph 5
And your in-game net_graph 5

Can you see difference before and after lag start?

*edit
What if you get rid off that grenade-trail plugin for awhile.

Arad119 07-19-2021 10:19

Re: [CS:GO] Nades are laggy
 
Quote:

Originally Posted by Bacardi (Post 2753106)
Enable net_graph 5 in your game.

In server sv_max_allowed_net_graph 5
And your in-game net_graph 5

Can you see difference before and after lag start?

*edit
What if you get rid off that grenade-trail plugin for awhile.

I tried disabling the grenade-trail plugin (Practice mode) but the results I got were the exact same as if I had practice mode on.

The main difference I found was that when the nades wasn't lagging one of the values were at 129/s whilst it was at 24/s when the nades were lagging.

Results: https://i.imgur.com/YNLeoyx.png

*Edit
One of the "in" values also decreased from 22k (without lag) to 5k (with lag)

Bacardi 07-19-2021 12:57

Re: [CS:GO] Nades are laggy
 
- Your CHOKE is 0% = Your rate is not too low, not limiting update rate. Good.
- Your LOSS is 0% = Problem should not be on server side...
- Server is tick:128
- Your up: and cmd: 128 = Your cl_updaterate and cl_cmdrate is 128 (or server restrict into those)

But your update rate is still limited to 24.

I managed to get that "bug" with these steps:
- Player join in server, not join in team or is going to spectator team.
- Server sv_minupdaterate changed to 0 or 24
- Player set cl_upraterate 24
- After this server change sv_minupdaterate 128 while player is in game.

- This action restrict player convar cl_updaterate to 128, but this has not fix player actual update rate yet.
- Player need reconnect to server for fix changed update rate.


You can check cvars current value by typing only cvar name. But it maybe not help if those values change over map change or something.
sm_cvar sv_minupdaterate
sm_cvar sv_maxupdaterate



You maybe need look and remove all cvars from server configs.
sv_minupdaterate
sv_maxupdaterate

... And if you have "rate" plugins, remove those as well.

You maybe need look in your own game, you have not "rate" button bindings or config files with rates.

*edit
And this is now my guess.

Arad119 07-20-2021 11:48

Re: [CS:GO] Nades are laggy
 
Quote:

Originally Posted by Bacardi (Post 2753162)
- Your CHOKE is 0% = Your rate is not too low, not limiting update rate. Good.
- Your LOSS is 0% = Problem should not be on server side...
- Server is tick:128
- Your up: and cmd: 128 = Your cl_updaterate and cl_cmdrate is 128 (or server restrict into those)

But your update rate is still limited to 24.

I managed to get that "bug" with these steps:
- Player join in server, not join in team or is going to spectator team.
- Server sv_minupdaterate changed to 0 or 24
- Player set cl_upraterate 24
- After this server change sv_minupdaterate 128 while player is in game.

- This action restrict player convar cl_updaterate to 128, but this has not fix player actual update rate yet.
- Player need reconnect to server for fix changed update rate.


You can check cvars current value by typing only cvar name. But it maybe not help if those values change over map change or something.
sm_cvar sv_minupdaterate
sm_cvar sv_maxupdaterate



You maybe need look and remove all cvars from server configs.
sv_minupdaterate
sv_maxupdaterate

... And if you have "rate" plugins, remove those as well.

You maybe need look in your own game, you have not "rate" button bindings or config files with rates.

*edit
And this is now my guess.

I know for a fact that I've had sv_minupdaterate and sv_maxupdaterate in the server config before, I removed them now. Will update you in a couple of hours if that fixed the issue.

Bacardi 07-20-2021 12:36

Re: [CS:GO] Nades are laggy
 
Check also your own game cfg files...

And post sm plugins list

You are using SRCDS? (Not in-game listen server)

Arad119 07-20-2021 16:25

Re: [CS:GO] Nades are laggy
 
Quote:

Originally Posted by Bacardi (Post 2753237)
Check also your own game cfg files...

And post sm plugins list

You are using SRCDS? (Not in-game listen server)

UPDATE: The same problem still happens even with sv_minupdaterate and sv_maxupdaterate removed from the server configs.

Yes, the server is hosted via srcds. I checked my game config files and they don't have any rate commands. The problem is noticeable for everyone that joins the server, not just for me.

Here's the sm plugins list:
"Admin File Reader" (1.10.0.6502) by AlliedModders LLC
"Admin Help" (1.10.0.6502) by AlliedModders LLC
"Admin Menu" (1.10.0.6502) by AlliedModders LLC
"Anti-Flood" (1.10.0.6502) by AlliedModders LLC
"Basic Ban Commands" (1.10.0.6502) by AlliedModders LLC
"Basic Chat" (1.10.0.6502) by AlliedModders LLC
"Basic Comm Control" (1.10.0.6502) by AlliedModders LLC
"Basic Commands" (1.10.0.6502) by AlliedModders LLC
"Basic Info Triggers" (1.10.0.6502) by AlliedModders LLC
"Basic Votes" (1.10.0.6502) by AlliedModders LLC
"Bot Mimic" (2.1) by Jannik "Peace-Maker" Hartung
"Client Preferences" (1.10.0.6502) by AlliedModders LLC
"Fix Competitive Warmup" (1.0) by Ilusion9
"Fun Commands" (1.10.0.6502) by AlliedModders LLC
"Fun Votes" (1.10.0.6502) by AlliedModders LLC
"Nextmap" (1.10.0.6502) by AlliedModders LLC
"Player Commands" (1.10.0.6502) by AlliedModders LLC
"CS:GO PracticeMode" (1.3.3) by splewis
"CS:GO PugSetup" (2.0.5) by splewis
"Reserved Slots" (1.10.0.6502) by AlliedModders LLC
"Sound Commands" (1.10.0.6502) by AlliedModders LLC
"Source Scramble Manager" (1.2.0) by nosoop

Bacardi 07-20-2021 16:48

Re: [CS:GO] Nades are laggy
 
Could you try one thing ?
When that lag happen and you see update rate held on 24,
go to spectator team, type in your own game console cl_updaterate 130, then go back in team T or CT.

Does update rate increase 24 -> 128 ?
*Seems using JUMP button in spect team fix bug as well.
*Seems using JUMP button in ct or t team while spectating other player fix bug as well.

*edit
What purpose is with this plugin ?
Source Scramble Manager

*edit
When map change or player connect to server, does server move player in team automatically ? So player have no time to choose team ?

Arad119 07-21-2021 08:56

Re: [CS:GO] Nades are laggy
 
Quote:

Originally Posted by Bacardi (Post 2753259)
Could you try one thing ?
When that lag happen and you see update rate held on 24,
go to spectator team, type in your own game console cl_updaterate 130, then go back in team T or CT.

Does update rate increase 24 -> 128 ?
*Seems using JUMP button in spect team fix bug as well.
*Seems using JUMP button in ct or t team while spectating other player fix bug as well.

*edit
What purpose is with this plugin ?
Source Scramble Manager

*edit
When map change or player connect to server, does server move player in team automatically ? So player have no time to choose team ?


I did some more testing, the update rate problem seems to happen during the server hibernation when no one is playing on the server. Upon disabling the server hibernation with sv_hibernate_when_empty 0, the update rate stays at 128 even after a couple of hours.

I'll enable the hibernate feature and test cl_updaterate 130 like you mentioned, will update you in a couple of hours.

Regarding Source Scramble Manager, I believe it was there from the beginning as I don't recall downloading it. Seems to allow plugins to allocate memory and such, more info about it here.

No, the server doesn't automatically move a player into a team upon joining. The players have roughly 15 seconds to choose whatever team they want to join.

pedrotski 07-21-2021 22:09

Re: [CS:GO] Nades are laggy
 
Quote:

Originally Posted by Arad119 (Post 2753255)
UPDATE: The same problem still happens even with sv_minupdaterate and sv_maxupdaterate removed from the server configs.

Why did you remove these? Setting them to 128 should force clients to be 128 tick.

Furthermore cl_ are client side only. If other people have the problem, that's not the issue.

Delete your entire server CFG and just add this

Quote:

sv_maxrate 0
sv_minrate 75000
sv_maxupdaterate 128
sv_minupdaterate 128
sv_maxcmdrate 128
sv_mincmdrate 128
sv_parallel_sendsnapshot 1
Setting min rates will force things not to go below that threshold.

Values like that shouldn't change for no reason.

Bacardi 07-22-2021 01:13

Re: [CS:GO] Nades are laggy
 
Read whole topic @pedrotski

pedrotski 07-22-2021 06:18

Re: [CS:GO] Nades are laggy
 
Quote:

Originally Posted by Bacardi (Post 2753341)
Read whole topic @pedrotski

I did. And it sounds like a server side config issue to me. Hence he should start with his server.cfg file and go from there. Start eliminating variables.

Arad119 07-27-2021 13:54

Re: [CS:GO] Nades are laggy
 
Sorry for the late reply, haven't been on the computer thus not being able to test commands and such.

Quote:

Originally Posted by Bacardi (Post 2753341)
Read whole topic @pedrotski

I tried cl_updaterate 130 but the problem still occured.

Quote:

Originally Posted by pedrotski (Post 2753356)
I did. And it sounds like a server side config issue to me. Hence he should start with his server.cfg file and go from there. Start eliminating variables.

Also tried your commands, seems to have fixed the problem. Don't know which one of the commands actually made the difference but anyways. Thanks for the help, much appreciated

pedrotski 07-27-2021 20:35

Re: [CS:GO] Nades are laggy
 
Quote:

Originally Posted by Arad119 (Post 2753820)
Sorry for the late reply, haven't been on the computer thus not being able to test commands and such.



I tried cl_updaterate 130 but the problem still occured.



Also tried your commands, seems to have fixed the problem. Don't know which one of the commands actually made the difference but anyways. Thanks for the help, much appreciated

Awesome glad its fixed :)!


All times are GMT -4. The time now is 07:55.

Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.