AlliedModders

AlliedModders (https://forums.alliedmods.net/index.php)
-   SourceBans / SourceBans++ (https://forums.alliedmods.net/forumdisplay.php?f=152)
-   -   Sourcebans 1.4.11 - PHP Error (https://forums.alliedmods.net/showthread.php?t=332264)

tmwb.blood 05-02-2021 16:02

Sourcebans 1.4.11 - PHP Error
 
We have been using 1.4.11 and had no issues, but gameservers recently stopped supporting older PHP and now we are getting all the errors below.

Basically our sourcebans is dead in the water. Is there an easy way to upgrade the PHP and just keep everything as is? By all means, please speak to me like I am a 10 year old who just received his first computer, that is about the extent of my knowledge. Just trying to figure out the easiest/quickest way to keep the server running. Thank you!

-------------------------------------------------------------------------
Error: the XML response that was returned from the server is invalid. Received:
Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; ADODB_Cache_File has a deprecated constructor in /home/cXXX/public_html/sb/includes/adodb/adodb.inc.php on line 263

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; ADOConnection has a deprecated constructor in /home/cXXX/public_html/sb/includes/adodb/adodb.inc.php on line 359

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; ADORecordSet has a deprecated constructor in /home/cXXX/public_html/sb/includes/adodb/adodb.inc.php on line 2919

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; ADORecordSet_array has a deprecated constructor in /home/cXXX/public_html/sb/includes/adodb/adodb.inc.php on line 3937

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Smarty has a deprecated constructor in /home/cXXX/public_html/sb/includes/smarty/Smarty.class.php on line 64

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; xajax has a deprecated constructor in /home/cXXX/public_html/sb/includes/xajax.inc.php on line 75

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; xajaxResponse has a deprecated constructor in /home/cXXX/public_html/sb/includes/xajaxResponse.inc.php on line 68

Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /home/cXXX/public_html/sb/includes/adodb/adodb.inc.php on line 1001

Warning: Cannot modify header information - headers already sent by (output started at /home/cXXX/public_html/sb/includes/adodb/adodb.inc.php:263) in /home/cXXX/public_html/sb/includes/CUserManager.php on line 189

Warning: Cannot modify header information - headers already sent by (output started at /home/cXXX/public_html/sb/includes/adodb/adodb.inc.php:263) in /home/cXXX/public_html/sb/includes/CUserManager.php on line 190

Warning: Cannot modify header information - headers already sent by (output started at /home/cXXx/public_html/sb/includes/adodb/adodb.inc.php:263) in /home/cXXX/public_html/sb/includes/CUserManager.php on line 191

Warning: Cannot modify header information - headers already sent by (output started at /home/cXXX/public_html/sb/includes/adodb/adodb.inc.php:263) in /home/cXXX/public_html/sb/includes/xajax.inc.php on line 766
$('msg-red').setStyle('display', 'none');

L4D2Noob 05-02-2021 19:40

Re: Sourcebans 1.4.11 - PHP Error
 
What's the php version now?
IP-Gamers.Net/ban has php version 7.4.15, Sourcebans version 1.6.3 and everything works fine.

L4D2Noob 05-02-2021 19:41

Re: Sourcebans 1.4.11 - PHP Error
 
Or do you definitely need to use an older version of Sourcebans, am I getting it right?

tmwb.blood 05-04-2021 15:15

Re: Sourcebans 1.4.11 - PHP Error
 
I dont need to use an older version of Sourcebans, I was just hoping there was an easy fix to get this one back up. I was just reading up on Sourcebans++ and how to make the switch. If that is my only option I am sure I can make it work, just we had no issues before, and who likes change? I mean, I am playing a game from 2004, haha.

Thanks!

L4D2Noob 05-04-2021 16:17

Re: Sourcebans 1.4.11 - PHP Error
 
1 Attachment(s)
Perhaps in your control panel it is possible to change the php version


All times are GMT -4. The time now is 07:17.

Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.