AlliedModders

AlliedModders (https://forums.alliedmods.net/index.php)
-   HLstatsX:CE (https://forums.alliedmods.net/forumdisplay.php?f=156)
-   -   Daemon suddenly stops receiving from servers (https://forums.alliedmods.net/showthread.php?t=328072)

heavyisgps 10-25-2020 14:48

Daemon suddenly stops receiving from servers
 
I'm doing some troubleshooting on windows and it seems the daemon just stops receiving or the servers stops sending to it on my local network. I have both linux and windows servers, however the daemon only runs on the windows machine.

I have to restart the tf2 server to get it to work again, unloading and reloading plugins, or turning log off or on doesn't work. So it seems to be some sort of set timer for how long it accepts inputs.

In the daemon window itself it just says - E400: Auto-disconnecting "Heavy Is GPS | Balancemod.tf" <P:1,U:2,W:1:1866507,T:Red> for idling (262 sec) on server (192.168.0.186:27017)

Even though things are still happening on the server.

Anyone knows what this is? I haven't gotten the exact timing down, but once that happens, the server needs to be restarted in order for it to deliver more data

Krillin 10-30-2020 18:06

Re: Daemon suddenly stops receiving from servers
 
Quote:

Originally Posted by heavyisgps (Post 2722521)
I'm doing some troubleshooting on windows and it seems the daemon just stops receiving or the servers stops sending to it on my local network. I have both linux and windows servers, however the daemon only runs on the windows machine.

I have to restart the tf2 server to get it to work again, unloading and reloading plugins, or turning log off or on doesn't work. So it seems to be some sort of set timer for how long it accepts inputs.

In the daemon window itself it just says - E400: Auto-disconnecting "Heavy Is GPS | Balancemod.tf" <P:1,U:2,W:1:1866507,T:Red> for idling (262 sec) on server (192.168.0.186:27017)

Even though things are still happening on the server.

Anyone knows what this is? I haven't gotten the exact timing down, but once that happens, the server needs to be restarted in order for it to deliver more data

Sounds like your game server data is not sending to HLSTATSX Daemon. A few things can be preventing this.

1. HLSTATS Daemon should have a STATIC IP address.
logaddress_add 1.2.3.4:27500 //[be sure your hosted IP address is set correctly.
2. Make sure the hlstats.smx file is in your plugin folder (you may have to compile it locally first)
3. Open the port 27500 in the firewall of your windows box (windows updates sometimes resets our
settings with updates with major releases. This is why windows server is ideal for this).
4. The hlstats.pl is not loading on start up on your windows machine after restarting and you have to
launch it manually.
5. You may have file corruption and may need to unzip the HLSTATS:CE and overwrite your files
except your hlstatsx.conf file.

Also, the daemon run and always sends data to the server and the server reports back. There isn't a timeout function within HLSTATSX.

Quote:

Originally Posted by HLSTATS.PL CONSOLE
2020-10-30 16:58:59: 192.168.1.5:27015 - E020: OK Rcon from "192.168.1.5": "stats"
2020-10-30 16:58:59: 192.168.1.5:27015 - MYSQL: Flushing player updates to database...
2020-10-30 16:58:59: 192.168.1.5:27015 - MYSQL: Flushing player updates to database is complete.
2020-10-30 16:58:59: 192.168.1.5:27015 - E020: OK Rcon from "192.168.1.5": "status"
2020-10-30 16:58:59: 192.168.1.5:27015 - E020: BAD DATA: rcon from "192.168.1.5:60859": command ""
2020-10-30 16:58:59: 192.168.1.5:27015 - E020: OK Rcon from "192.168.1.5": "sv_visiblemaxplayers"
2020-10-30 16:59:31: - SERVER: Insert new server load timestamp
2020-10-30 16:59:31: 192.168.1.5:27018 - E020: OK Rcon from "192.168.1.5": "stats"
2020-10-30 16:59:33: 192.168.1.5:27018 - MYSQL: Flushing player updates to database...
2020-10-30 16:59:33: 192.168.1.5:27018 - MYSQL: Flushing player updates to database is complete.
2020-10-30 16:59:33: 192.168.1.5:27018 - E020: OK Rcon from "192.168.1.5": "status"
2020-10-30 16:59:33: 192.168.1.5:27018 - E020: BAD DATA: rcon from "192.168.1.5:60901": command ""
2020-10-30 16:59:33: 192.168.1.5:27018 - E020: OK Rcon from "192.168.1.5": "sv_visiblemaxplayers"
2020-10-30 17:01:31: - HLSTATSX: No data since 120 seconds
2020-10-30 17:03:28: - HLSTATSX: Insert new server trend timestamp
2020-10-30 17:03:32: - HLSTATSX: No data since 120 seconds

My servers are running on the same machine and I DO NOT use "localhost" or 127.0.0.1 in ANY configuration except the database configuration. But the firewall is mostly overlooked.

Without you giving us any information on what you have done, what you have not done, nor showing us what plugins you are running. The lack of information is not helpful. :nono:

The documentation is pretty clear and steps should never be assumed they are working to move on to the next (we made this same mistake years ago and went through the documentation 5 or 6 times to get it working) the firewall was my problem because the data is being sent from outside of the box).

http://hlstatsx.krillinsworld.com

Krillin

heavyisgps 12-01-2020 13:34

Re: Daemon suddenly stops receiving from servers
 
Hi, well this used to work, and I made no changes and now it doesn't. Basically the TF2 server is logging it, but the Daemon stops receiving after what seems like a random number of minutes. The daemon still runs, if I restart the server, it receives for a while, then stops. I am running on windows 10. I do not have this issue with my linux servers.

I think it's related to when no data has been transmitted and the daemon autodisconnects me for being idle. After than nothing is picked up from the server. Not until the TF2 server is restarted

https://i.imgur.com/Y9CcRAo.png is the server logs, I also stripped all unnecessary plugins, so it only runs what it needs to with the HLX stats


All times are GMT -4. The time now is 06:13.

Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.