AlliedModders

AlliedModders (https://forums.alliedmods.net/index.php)
-   TF2Items (https://forums.alliedmods.net/forumdisplay.php?f=146)
-   -   Solved Can't get tf2_manager to work. (https://forums.alliedmods.net/showthread.php?t=330954)

topyke 02-28-2021 17:44

Can't get tf2_manager to work.
 
1 Attachment(s)
I have been trying to make a rebalance server for a while, and I've finally got all the pieces together, but the manager refuses to work, it gives this error:
[2021-02-28 17:21:50]: L 02/28/2021 - 22:21:50: [SM] Exception reported: TF2ItemType handle not created (error 10)
[2021-02-28 17:21:50]: L 02/28/2021 - 22:21:50:
[SM] Blaming: tf2items_manager.smx
[2021-02-28 17:21:50]: L 02/28/2021 -
22:21:50: [SM] Call stack trace:
[2021-02-28 17:21:50]: L 02/28/2021 - 22:21:50: [SM] [0] TF2Items_CreateItem
[2021-02-28 17:21:50]: L 02/28/2021 - 22:21:50: [SM] [1] Line 350, C:\Users\Zack\Desktop\addons\sourcemod\script ing\tf2items_manager.sp::ParseItemsEntry
[2021-02-28 17:21:50]: L 02/28/2021 - 22:21:50: [SM] [2] Line 313, C:\Users\Zack\Desktop\addons\sourcemod\script ing\tf2items_manager.sp::ParseItems
[2021-02-28 17:21:50]: L 02/28/2021 - 22:21:50: [SM] [3] Line 58, C:\Users\Zack\Desktop\addons\sourcemod\script ing\tf2items_manager.sp::OnPluginStart
[2021-02-28 17:21:50]: [SM] Plugin tf2items_manager.smx failed to load: Error detected in plugin startup (see error logs).

I attached my config in case I messed that up.



I really want to make this work, and I know if I fix this it will work, I'd be very happy if you guys could help me out.

asherkin 03-01-2021 05:08

Re: Can't get tf2_manager to work.
 
The error you're getting here shouldn't be possible - it implies an internal error in TF2Items registering things with SourceMod. What version of SourceMod (sm version) and what version of TF2Items (sm exts list, sm exts info [number next to tf2items]) are you using? Also make sure you don't somehow have two copies of the tf2items extension loaded.

topyke 03-01-2021 08:08

Re: Can't get tf2_manager to work.
 
I actually had 2 TF2items loaded, so that fixed that, but now I have this error,
[2021-03-01 08:03:08]: L 03/01/2021 - 13:03:08:
[SM] Exception reported: Cowardly refusing to add invalid attribute index "0" to an item.
[2021-03-01 08:03:08]: L 03/01/2021 - 13:03:08:
[SM] Blaming: tf2items_manager.smx
[2021-03-01 08:03:08]: L 03/01/2021 - 13:03:08:
[SM] Call stack trace:
[2021-03-01 08:03:08]: L 03/01/2021 - 13:03:08:
[SM] [0] TF2Items_SetAttribute
[2021-03-01 08:03:08]: L 03/01/2021 - 13:03:08: [SM] [1] Line 425, C:\Users\Zack\Desktop\addons\sourcemod\script ing\tf2items_manager.sp::ParseItemsEntry[2021-03-01 08:03:08]: L 03/01/2021 - 13:03:08:
[SM] [2] Line 313, C:\Users\Zack\Desktop\addons\sourcemod\script ing\tf2items_manager.sp::ParseItems
[2021-03-01 08:03:08]: L 03/01/2021 - 13:03:08: [SM] [3] Line 58, C:\Users\Zack\Desktop\addons\sourcemod\script ing\tf2items_manager.sp::OnPluginStart
[2021-03-01 08:03:08]: [SM] Plugin tf2items_manager.smx failed to load: Error detected in plugin startup (see error logs).

I've seen a post before that this has something to do with my config, which I have attached on my first post, if you could help me with this I'd greatly appreciate it.

asherkin 03-01-2021 11:21

Re: Can't get tf2_manager to work.
 
On line 16 you are attempting to set an attribute with an ID of 0 (which doesn't exist).

topyke 03-01-2021 11:38

Re: Can't get tf2_manager to work.
 
That fixed the problem, thank you so much for your help and patience!


All times are GMT -4. The time now is 12:33.

Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.