AlliedModders (
-   Metamod:Source Questions (
-   -   No bin folder in metamod folder (

Bamowen 09-26-2018 18:29

No bin folder in metamod folder
Hello everyone!

So I've downloaded metamod from here, and unzipped the file.
I followed the instructions here but the commands weren't working.

As I investigated into the issue, I notice that the sourcemod.vdf I generate from here looks like this :

"file" "../csgo/addons/metamod/bin/server"

HOWEVER, my metamod folder only has one file : sourcemod.vdf
No bin folder, nothing else than this file.
I've tried downloading both stable 1.9 and 1.10 - 6334, both with same results.

I suppose this is the reason metamod (and thus sourcemod) can't initialize?

Please help.


Fyren 09-27-2018 03:12

Re: No bin folder in metamod folder
You did not unzip/upload the contents of the MM:S zip correctly. The sourcemod.vdf file is from the SM zip.

Bamowen 09-27-2018 04:17

Re: No bin folder in metamod folder
Weird, I tried looking inside the zip before unzipping it, and I still don't have any bin folder

I extracted with 7-zip, and uploaded by drag and dropping folders in Filezilla.

psychonic 09-27-2018 15:22

Re: No bin folder in metamod folder
That is SourceMod, not Metamod. You can get Metamod from

Bamowen 09-29-2018 14:44

Re: No bin folder in metamod folder
Thanks for the answer, I downloaded the wrong plugin. I now have the bin folder.

However, I follow the instructions on how to install metamod, Unzip locally, drag & drop the addons folder in csgo folder on filezilla, and restart the server (tried it with serv live and stopped).

And it still doesn't recognize the command : rcon meta version (or just meta version when doing it from the provider's website). I got a "Unknown command "meta"", other rcon command work fine.

What am I doing wrong ? Shall I create a new thread ?

Thanks in advance

Fyren 09-29-2018 18:55

Re: No bin folder in metamod folder
Check to see that the files from the MM:S zip are actually where they need to be. You should, for example, end up with addons/ next to your server's server.cfg and gameinfo.txt, and inside that there should be metamod.vdf (and the rest of the files from the zip).

Make sure you chose the right archive (.zip is Windows, .tar.gz is Linux) for your server's OS.

Make sure you're getting the most recent build of MM:S (as far as I know, either branch would work).

Make sure your server is updated.

Depending at which point things are going wrong, you may have a metamod-fatal.log file with info in metamod/bin/.

All times are GMT -4. The time now is 15:27.

Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.