AlliedModders

AlliedModders (https://forums.alliedmods.net/index.php)
-   (OLD) Bug Reports (https://forums.alliedmods.net/forumdisplay.php?f=48)
-   -   [Fixed] Invalid Player 3 on Agent Zero (https://forums.alliedmods.net/showthread.php?t=34879)

v_one 10-23-2005 04:23

[Fixed] Invalid Player 3 on Agent Zero
 
Spec:
Linux
AMXX 1.60
Metamod 1.18
Vault
SHMOD 1.18d CVS

Don't know what this is, but took up 1/2 of the log page. (Almost 1/2)

Bug:
Code:

L 10/19/2005 - 16:10:29: [ENGINE] Invalid player 3 (not in-game)
L 10/19/2005 - 16:10:29: [AMXX] Displaying debug trace (plugin "sh_agentzero.amxx")
L 10/19/2005 - 16:10:29: [AMXX] Run time error 10: native error (native "entity_set_vector")
L 10/19/2005 - 16:10:29: [AMXX]    [0] sh_agentzero.sma::client_PreThink (line 64)


Freecode 10-23-2005 04:38

redownload it tell me if same error happens

v_one 10-23-2005 04:41

If I could take out the agentz.sma , maybe i can recompile it.. :roll:

Freecode 10-23-2005 04:48

now?

v_one 10-23-2005 04:49

Yeah now
I couldn't take out the .sma

Edited: Notice this "Last edited by Freecode on Sat Oct 22, 2005 11:56 pm; edited 3 times in total" for the second time, the .sma did work, no need to post a seperate sma for the 3rd time since i could take out the sma the 2nd time of your edit. :wink:

Freecode 10-23-2005 04:57

arg!!! wtf.
there i attached an sma file. just compile it

jtp10181 10-23-2005 10:29

FYI the sma extracts just fine out of the zip file

jtp10181 11-30-2005 23:19

Freecode did you ever post the fixed one in the heroes post?

Sir-LaggAlot 11-30-2005 23:38

I think he did posted his fixed hero
I still had the old agentz version while he only added 1 extra thing to prevent that invalid player thing
Code:
if(gHasAgent[id] && is_user_alive(id))

and the one before was only
Code:
if(gHasAgent[id])
on the PreThink fucntion

but im still getting that invalid player on this updated hero .

jtp10181 12-01-2005 00:18

he never updated the compiled amxx in the download. I just updated the sma and amxx in the download. Please try it and let me know if the errors continue.


All times are GMT -4. The time now is 11:11.

Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.