AlliedModders

AlliedModders (https://forums.alliedmods.net/index.php)
-   (OLD) Bug Reports (https://forums.alliedmods.net/forumdisplay.php?f=48)
-   -   Error on shaman (https://forums.alliedmods.net/showthread.php?t=36500)

infernal2 05-31-2006 09:00

Error on shaman
 
Whell i hawe this error on shaman...dont know what else i can say if i write debug shaman dostn show in the menu wher u can chose heros ...
Code:

Invalid player id 0
[AMXX] Run time error 10 <plugin "sh_shaman.amxx"> - de bug not enabled
[AMXX] To enable debug mode, add "debug" after the plugin name in the plugins.ini <whitout quotes>


D o o m 06-01-2006 04:19

So in the plugins.ini stands
Code:

sh_shaman.amxx debug
?
If yes, it will work and if you write "debug", it's your own fault :P

I don't know another explanation (is this word right? *lol*).

infernal2 06-01-2006 04:49

w8 so i didnt get it
when i hawe
sh_shaman.amxx debug it dosnt work compleatly and if
sh_shaman.amxx it givs me thos lines

Emp` 06-01-2006 10:06

its an error in the hero, ill fix it when i get back from school

infernal2 06-01-2006 10:45

ok ye thx cant w8 =]

Emp` 06-01-2006 19:56

change line 145
Code:

        if ( is_user_alive(id) && id != attacker && gIsZombie[id] ) {
to
Code:

        if ( is_user_alive(id) && is_user_alive(attacker) && id != attacker && gIsZombie[id] ) {
that should fix it, tell me if it does

infernal2 06-02-2006 09:09

thx emp evrything is a ok :D

infernal2 06-04-2006 08:08

srry emp about that a ok think cuz whell it was ok but it started 2 show the same thing...

Emp` 06-04-2006 13:16

enable debug and whats it print?

infernal2 06-10-2006 14:32

so srry emp about the late replay

Code:

Invalid player id 0
[AMXX] Displaying debug trace <plugin "sh_shaman.amxx">

[AMXX] Run time error 10: native error <native "get_user_attacker">
[AMXX]    [0] sh_shaman.sma::Shaman_damage <line 143>

somthing like that :D


All times are GMT -4. The time now is 07:16.

Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.