AlliedModders (
-   HLstatsX:CE (
-   -   [SOLVED] TRCON: Trying to get rcon access (auth) - can't receive junk packet? (

CrazyKermitRubes 09-24-2020 18:59

[SOLVED] TRCON: Trying to get rcon access (auth) - can't receive junk packet?
Well, I had everything working for a day and then the in-game commands stopped working.
HLstatsx CE 1.7 for TF2 servers running on CentOS 8.
Basically, it looks like hlstats cannot get rcon access.
It doesn't look like I'm getting an error, just that the junk packet isn't returned.

hlstats and game server are on the same host.

It looks like it's still tracking stats or at the very least getting information from the game servers.
There is data that is getting added to the mysql database.

I added +ip and -usercon to the server's run parameters.

The servers' are added like this:
IP Address Port Public Address
public ip address of game server, port of game server public ip address:portofgameserver

HLstatsX: CE Daemon Control
localhost and port 27500

logaddress is set to publicaddress:27500
I also tried adding (not deleting the other log address) and restarting daemon, but I get the same problem.

I know the rcon passwords are set correctly because I am not receiving that error message and I can get rcon access using that password.

I'm thinking some other address should go in the daemon control, but I'm not sure what.

Ports are all open on the firewall.

Thanks to Domino_ on Discord, I found out that the server banned itself because of too many mismatching password attempts by hltstats. So the lesson here is, when changing rcon password, stop the daemon. Also, make sure the game server doesn't ban the hlstats server because of too many rcon attempts. (listip in server console)

CrazyKermitRubes 09-27-2020 00:47

Re: TRCON: Trying to get rcon access (auth) - can't receive junk packet?
So in my attempt to figure out what is going on I figured out that it's never calling recieve_rcon in Could that be because the server isn't responding back to the rcon request? Why would that be if everything else is setup fine?

All times are GMT -4. The time now is 05:19.

Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.