AlliedModders

AlliedModders (https://forums.alliedmods.net/index.php)
-   Metamod:Source Questions (https://forums.alliedmods.net/forumdisplay.php?f=74)
-   -   Bug from Metamod (https://forums.alliedmods.net/showthread.php?t=263627)

mikize 05-29-2015 15:22

Bug from Metamod
 
Hi,

I want to run my server but a weird error happened, I get this error

Code:

Missing shutdown function for sv.Init( bDedicated ) : sv.Shutdown()
I reinstalled everything and it works but metamod and sourcemod weren't here. Tried without sourcemod only metamod, it doesn't work and same with sourcemod. I tried to update metamod and didn't work.

versatile_bfg 06-02-2015 02:59

Re: Bug from Metamod
 
Get the latest snapshot from the stable branch for metamod and sourcemod [if you are using sourcemod]
http://www.metamodsource.net/snapshots - current latest is - 1.10.6-git940
http://www.sourcemod.net/snapshots.php - current latest is - 1.7.3-git5209

Once you have extracted these to the server then update the server one more time and see if the issue still happens.

almil36 09-02-2019 09:02

Re: Bug from Metamod
 
Hi!

Sorry for bumping this thread but I got the same error coming up today on Windows. I tried reinstalling my csgo dedicated server. It launches well without sourcemod / metamod but when I add the sourcemod and metamod files in the csgo folder, I get the error: "Missing shutdown function for sv.Init( bDedicated ) : sv.Shutdown()" when starting the server.

Sourcemod version: 1.9 - build 6281
Metamod version: 1.10 - build 970

What is even more strange is that it was working last week and it does not seem that there were any updates this weekend. I even have Linux servers working normally today.

EDIT: So I have been looking more in details at the error and more specifically at the .mdmp file created by this crash and here is the output:
Dump File: srcds_2117156_crash_2019_9_2T13_1_27C0.mdmp : C:\csgo-ds\srcds_2117156_crash_2019_9_2T13_1_27C0.mdm p
Last Write Time: 02.09.2019 15:01:27
Process Name: srcds.exe : C:\csgo-ds\srcds.exe
Process Architecture: x86
Exception Code: 0xC0000005
Exception Information: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
Heap Information: Not Present


Still don't know how to solve this but it seems that it is an access error...
Let me know if you have any idea.

kryddersonn 09-02-2019 15:14

Re: Bug from Metamod
 
Im also getting the same error : "Missing shutdown function for sv.Init( bDedicated ) : sv.Shutdown()" when starting the server. Im not an expert what so ever about sm/mm but I have semi big community and they want their servers back up running =) I can pay if someone knows how to fix/finds solution.

Cruze 09-02-2019 21:44

Re: Bug from Metamod
 
Quote:

Originally Posted by kryddersonn (Post 2665633)
Im also getting the same error : "Missing shutdown function for sv.Init( bDedicated ) : sv.Shutdown()" when starting the server. Im not an expert what so ever about sm/mm but I have semi big community and they want their servers back up running =) I can pay if someone knows how to fix/finds solution.

Yeah same for my windows server. Linux works fine.

almil36 09-03-2019 02:44

Re: Bug from Metamod
 
Update of Metamod (1.10 - build 971) and Sourcemod (1.9 - build 6282) solved the issue.

Cheers


All times are GMT -4. The time now is 04:30.

Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.