AlliedModders

AlliedModders (https://forums.alliedmods.net/index.php)
-   Plugins (https://forums.alliedmods.net/forumdisplay.php?f=108)
-   -   Updater (https://forums.alliedmods.net/showthread.php?t=169095)

asherkin 02-10-2015 11:05

Re: Updater
 
HTTPS update manifest URLs are not supported.

ImACow 02-10-2015 11:09

Re: Updater
 
Quote:

Originally Posted by asherkin (Post 2260757)
HTTPS update manifest URLs are not supported.

Just tried with curl & sockets. both do not work with HTTPS as you said.
bummer

ImACow 02-10-2015 11:16

Re: Updater
 
The curl library does support https tho. so this requires a change on Updaters side ?

Powerlord 02-10-2015 14:12

Re: Updater
 
Quote:

Originally Posted by ImACow (Post 2260767)
The curl library does support https tho. so this requires a change on Updaters side ?

Updater intentionally doesn't support HTTPS as Socket doesn't support it, and you can't guarantee that Curl, SteamTools, or SteamWorks is the API being used.

ImACow 02-25-2015 07:03

Re: Updater
 
#define UPDATE_URL "https://"
#define UPDATE_FALLBACK_URL "http://"

I do understand that you want to get support from all 3, but given the fact that some support HTTPS its weird not to support HTTPS for 2 of the 3.

Benoist3012 04-05-2015 04:51

Re: Updater
 
We must have every link like this

http.alliedmodders.net/plugin/updater.smx
http.alliedmodders.net/scripting/updater.sp

or we can have the link like this:

http.alliedmodders.net/58?IKLFR
http.alliedmodders.net/6587MH?J

Ps:This links don't exist, but I have similar link for my plugins.

Dr. McKay 04-05-2015 13:42

Re: Updater
 
Quote:

Originally Posted by Benoist3012 (Post 2282075)
We must have every link like this

http.alliedmodders.net/plugin/updater.smx
http.alliedmodders.net/scripting/updater.sp

or we can have the link like this:

http.alliedmodders.net/58?IKLFR
http.alliedmodders.net/6587MH?J

Ps:This links don't exist, but I have similar link for my plugins.

No redirects or HTTPS.

nelioneil 04-20-2015 18:31

Re: Updater
 
Getting this message:

"[UPDATER] Unsupported SourceMod version. Please upgrade."

Using snapshop 1.7.2-dev+5191 for windows

versatile_bfg 04-20-2015 19:11

Re: Updater
 
Quote:

Originally Posted by nelioneil (Post 2288471)
Getting this message:

"[UPDATER] Unsupported SourceMod version. Please upgrade."

Using snapshop 1.7.2-dev+5191 for windows

This isn't a part of the Updater plugin but apart of Sourcemod itself.

Refer to this thread: https://forums.alliedmods.net/showthread.php?p=2288211

5th, 8th & 9th post.

GBLTeam 05-05-2015 08:20

Re: Updater
 
Is this working or no ?


All times are GMT -4. The time now is 21:02.

Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.