AlliedModders

AlliedModders (https://forums.alliedmods.net/index.php)
-   Off-Topic / General Chat (https://forums.alliedmods.net/forumdisplay.php?f=38)
-   -   SuperHero 1.2.0.14 for AMX Mod X 1.8.0 or above - 11/07/2009 (https://forums.alliedmods.net/showthread.php?t=76081)

vittu 08-17-2008 22:18

SuperHero 1.2.0.14 for AMX Mod X 1.8.0 or above - 11/07/2009
 
3 Attachment(s)
WARNING: I will NOT support running 100+ heroes, if you are running that much do not expect not to have issues.

Click Here for the Changelog (Note: will update this link with a complete change log later)
Click Here for the Current Source Code on SVN


------------------------------------------------------------
REQUIREMENTS
------------------------------------------------------------


  • Counter-Strike 1.6 or Counter-Strike: Condition Zero

  • AMX Mod X 1.8.0 or above /w Counter-Strike Addon
    (Note: AMX Mod X 1.8.1 is highly recommend over 1.8.0, due to various fixes)
    AMX Mod X Modules Required:
    fun
    fakemeta
    ham sandwich
    cstrike
    csx

    mysql (optional dependent on save method)
    nvault (optional dependent on save method)
    (Note: many heroes will require "engine" as well)
  • Heroes must be compiled with new includes or else they will not work


**Optional Requirements for certain heroes located in the Contribution package (superheromod_AMXX_contrib.zip)
MonsterMod 3.00.00 (required for Skeletor and/or other heroes that use MonsterMod)
Models for Bomberman, Morpheus, and Wolverine.
------------------------------------------------------------
If upgrading to SuperHero Mod 1.2.0, from all previous versions.
------------------------------------------------------------
  • You must have AMX Mod X 1.8.0 or above w/Counter-Strike addon already installed. AMX Mod X 1.8.1 is recommend over 1.8.0.

  • You must recompile all heroes with the new includes.
    Web compiler has been updated with SH 1.2.0.10 includes.
    DO NOT ASK HOW TO COMPILE, search the forums or read amxmodx docs. There is plenty of info on how to do this simple procedure.
    Note: Some heroes will not compile without small code changes (ie. any expoding bullet hero, or heroes that register cvars after shCreateHero). Please post in affected hero's post to ask for them to be updated.

  • You must make the following changes in plugins-shero.ini (or plugins.ini) due to renamed heroes.
    • Remove:
      sh_nightcrawler.amxx
      sh_windwalker.amxx
      sh_zues.amxx

    • Add:
      sh_blackpanther.amxx
      sh_grandmaster.amxx
      sh_shadowcat.amxx

    Note: These are the same heroes with updated names.
    Nightcrawler is now Shadowcat
    Windwalker is now Black Panther
    Zues is now Grandmaster


  • You must make some changes to shconfig.cfg. Check packaged shconfig.cfg for more info on a particular cvar.
    • Rename:
      sh_bombhostxp to sh_objectivexp
      nightc_level to shadowcat_level
      nightc_cooldown to shadowcat_cooldown
      nightc_cliptime to shadowcat_cliptime
      punisher_dropwpn to punisher_rldmode (cvar value has new meaning)
      windwalker_level to blackpanther_level
      zeus_level to gmaster_level
      zeus_cooldown to gmaster_cooldown

    • Remove (now unused):
      bomberman_xpbased (now controled by bomberman_bpl)
      ironman_armorfuel (now controled by ironman_fuelcost)
      **Note: be aware of these changes, bomberman_bpl and ironman_fuelcost are now active if greater than 0.

    • Add:
      sh_reloadmode (sever wide setting for reload native used only if hero does not use a setting or sets 0.)
      Possible values:
      0 = normal reload
      1 = unlimited ammo/no reload (Default)
      2 = unlimited bpammo/requires reload
      3 = unlimited ammo/drop weapon
      sh_minplayersxp (minimum players needed to be in server before bonus xp is awarded. ie mecry, hostage, bomb, vip.)
      value: number of players. This helps against xp farming. (Default 2)
      sh_blockvip (set what you want to block vip from having. ie can block vip from getting weapons or useing +powers)
      value: flags "abcdefgh" available. Please see superheroconst.inc for flag values. (Default "abcdef")

**Optional for MySQL saving servers. These changes are not necessary:
(if you ask how to do these your post will be immediately trashed)
(if prior to 1.17.5 run all)
Code:

//Upgrade from SuperHero Mod prior to 1.17.5
ALTER TABLE `sh_savexp` ADD `HUDHELP` TINYINT( 3 ) UNSIGNED DEFAULT '1' NOT NULL AFTER `XP`;

//Upgraded from SuperHero Mod prior to 1.2.0 (XP from unsigned to signed and usage of tinyint over int)
ALTER TABLE `sh_savexp` CHANGE `XP` `XP` INT( 10 ) SIGNED NOT NULL DEFAULT '0';
ALTER TABLE `sh_savexp` CHANGE `HUDHELP` `HUDHELP` TINYINT( 3 ) UNSIGNED NOT NULL DEFAULT '1';
ALTER TABLE `sh_savexp` CHANGE `SKILL_COUNT` `SKILL_COUNT` TINYINT( 3 ) UNSIGNED NOT NULL DEFAULT '0';
ALTER TABLE `sh_saveskills` CHANGE `SKILL_NUMBER` `SKILL_NUMBER` TINYINT( 3 ) UNSIGNED NOT NULL DEFAULT '0';


------------------------------------------------------------
AMX Mod X 1.8.1 Downloads
------------------------------------------------------------


These are the files you might need if you don't already have AMX Mod X installed.


Download AMX Mod X Auto-Installer
**be sure to select the Couter-Strike addon from the drop down menu during installation

- OR -

Download Metamod-p (or Metamod) plus AMX Mod X Base - and - Counter-Strike Addon [You NEED Both]
(Instructions)
- Alternatively available AMX Mod X Nightly Builds
------------------------------------------------------------

Note: SuperHero Mod Auto-Installer Discontinued. Due to inability to keep updated with latest amxmodx.
Compile package (superheromod_AMXX_compile.zip) also discontinued. As it is not really needed anymore.

------------------------------------------------------------

- Package is compiled for AMX Mod X 1.8.1 -
- If upgrading read the directions above before downloading for important info -

vittu 08-18-2008 01:16

Re: SuperHero 1.2.0 for AMX Mod X 1.8.0 or above - 08/17/2008
 
Version 1.18e downloads are still available here:
http://forums.alliedmods.net/showthread.php?t=31012


All times are GMT -4. The time now is 05:05.

Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.