AlliedModders

AlliedModders (https://forums.alliedmods.net/index.php)
-   HL1 Servers (HLDS) (https://forums.alliedmods.net/forumdisplay.php?f=131)
-   -   Solved HLDS not responding (https://forums.alliedmods.net/showthread.php?t=327382)

mentesh 09-15-2020 15:25

HLDS not responding
 
Greetings,

I am trying to run a HLDS server (CS 1.6), no mods, no addons, completely stock, following these instructions: https://developer.valvesoftware.com/wiki/SteamCMD. I have tried installing on CentOS 7, Ubuntu 18.04 and Ubuntu 20.04. All was fine a few days ago, but now, after startup, I can't type anything into server console and the server is not responding.

Here is the startup command I use:
Code:

./hlds_run -autoupdate -game cstrike +map de_dust2 +maxplayers 10
And here is the output:
Code:

Auto-restarting the server on crash
Could not locate steam binary:steamcmd/steamcmd.sh, ignoring.

Console initialized.
Using breakpad crash handler
Setting breakpad minidump AppID = 10
Forcing breakpad minidump interfaces to load
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Protocol version 48
Exe version 1.1.2.7/Stdio (cstrike)
Exe build: 19:52:19 Aug  3 2020 (8684)
STEAM Auth Server
Server IP address 172.26.3.27:27015
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
FATAL ERROR (shutting down): Unable to initialize Steam.

Linking steamclient.so as described here, does not resolve the issue.
I am out of ideas :(

UPDATE:
When I start HLDS without specifying map, it works. As soon as I run map command the console is stuck and I can't type anything.

UPDATE:
Solved by linking steamclient.so in /usr/lib


All times are GMT -4. The time now is 18:41.

Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.