PDA

View Full Version : Locations aren't showing up


Dariz
03-08-2013, 10:46
Dear HlstatsX:CE users.

I've finally managed to fix some my website problems, and now got the whole thing up and running.
Everything is working, besides the locations and the server load usage graph.

I have my installation in the folder /var/www/stats and my scripts /var/scripts
Also I have already installed the install_binary.sh in the Geo folder, so everything should be working. Awards etc is working and have added a cronjob for updating that.

What would be the problem? Neither server usage graph is generated or the locations of players or even server.

SINEKT
03-08-2013, 12:16
I solved the map problem instaling the Geo::IP: PurePerl module, for Perl. I don't remember exactly what I did, but google it up, one command I did was perl -MCPAN -e 'install Geo::IP: PurePerl', (from command history), and then entered cpan to actually install the module (don't remember the command I used here). Finally, you have to configure it from the admin interface to use the binary file for GeoIP - not database.

As for the graph problem, I still have it. I managed to successfully recompile PHP with GD, as one user suggested, but graphs still don't work. I would also greatly appreciate any help on this one...

Dariz
03-10-2013, 15:07
I have been trying for hours now, but I really fail at some point.
I'm doing as stated in the "INSTALL" file, and I have installed and updated everything that's possible.

But I keep getting this error, then I do perl Makefile.PL

Your installed version of libgeoip is outdated! Please update to at least
version to 1.5.0 and reinstall this module.
I tried updating libgeoip, libgeoip-dev etc. But everything seems to be up-to-date. I did a search on the Debian package sources, and the newest version is 1.4... ? How would I ever be able to update it to 1.5.0?

SINEKT
03-10-2013, 17:21
Found it. Try this instead:


Via linux command line (cli)
To install Geo::IP: PurePerl via cli you will need to be root and type the following:
Code:
perl -MCPAN -e 'install Geo::IP: PurePerl' (no space before "PurePerl", the forum converts it to smiley)

Again go to a linux command line. Do the following as root:
Code:
cpan install Geo::IP: PurePerl (no space before "PurePerl", the forum converts it to smiley)
It should now be installed.
You're lucky with me, I have questions unanswered for months... :D

Dariz
03-10-2013, 17:37
I typed as you said, and without the spacing - I just get the following error.


syntax error at -e line 1, near "Geo::IP:"
Execution of -e aborted due to compilation errors.

SINEKT
03-10-2013, 21:12
My bad, sorry, you need two colons the second time as well, so the commands will be:

perl -MCPAN -e 'install Geo::IP:: PurePerl' (no space before "PurePerl")

and

cpan install Geo::IP:: PurePerl (no space before "PurePerl")